Bug 819465 - Support partial repositories for anaconda
Support partial repositories for anaconda
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: python-virtinst (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-07 06:33 EDT by Kamil Páral
Modified: 2013-05-27 04:52 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-26 08:32:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kamil Páral 2012-05-07 06:33:10 EDT
Description of problem:
This is a "clone" of bug 790348. Anaconda developers stated that users should use repo= boot argument when providing a link to a full repository (including yum package repository), and stage2= boot argument when providing a link to a partial repository (without yum package repository).

Unfortunately virt-install always passes repo= arguments, so partial repositories don't work with it.

Partial repositories are used for testing Fedora development composes, or they can be used for PXE/VM spinning when you want to store just the anaconda installer locally, but not the whole yum repo.

Please find some way how to enable partial repository support inside anaconda. Some of possible ways were mentioned in bug 790348 comment 33. Another possible way is to talk to anaconda developers and convince them to change repo= behavior. But they don't seem to be inclined to go that way.

Version-Release number of selected component (if applicable):
python-virtinst-0.600.1-1.fc16.noarch

Steps to Reproduce:
1. virt-install --name Foo --ram 1024 --disk pool=default,size=10 --location http://dl.fedoraproject.org/pub/alt/stage/17.TC3/Fedora/i386/os/
(or use some another partial repository)
Comment 1 Cole Robinson 2012-10-26 08:32:24 EDT
Still not ideal for the reasons outlined here:

https://bugzilla.redhat.com/show_bug.cgi?id=790348#c21

But you can make it work with virt-install, probably want to turn it into a wrapper script though.

wget http://dl.fedoraproject.org/pub/alt/stage/18-Beta-TC6/Fedora/x86_64/os/images/pxeboot/initrd.img -O ~/.virtinst/boot/initrd.img
wget http://dl.fedoraproject.org/pub/alt/stage/18-Beta-TC6/Fedora/x86_64/os/images/pxeboot/vmlinuz -O ~/.virtinst/boot/vmlinuz

sudo virt-install --boot kernel=$HOME/.virtinst/boot/vmlinuz,initrd=$HOME/.virtinst/boot/initrd.img,kernel_args="stage2=http://dl.fedoraproject.org/pub/alt/stage/18-Beta-TC6/Fedora/x86_64/os/" --os-variant fedora17 ...

Closing as WONTFIX, but reopen if that workaround isn't sufficient and maybe we can figure something out.
Comment 2 Kamil Páral 2012-10-26 09:17:58 EDT
I believe anaconda in Fedora 18 now supports inst.repo= with incomplete repositories (just LiveOS/ directory, but no Packages/). They fall back to online repos in that case. If virt-install passes inst.repo= argument, then it should work seamlessly.
Comment 3 Cole Robinson 2012-10-26 09:35:18 EDT
indeed, --location seems to just work now when pointing to that URL

Note You need to log in before you can comment on or make changes to this bug.