Bug 819490 - Quick-read got hung while geo-replication session was on
Quick-read got hung while geo-replication session was on
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quick-read (Show other bugs)
mainline
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Raghavendra G
Vijaykumar Koppad
:
Depends On:
Blocks: 817967
  Show dependency treegraph
 
Reported: 2012-05-07 08:08 EDT by Vijaykumar Koppad
Modified: 2015-12-01 11:45 EST (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 14:02:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions: 3.3.0qa45
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Statedump of the aux mount process of the geo-rep session (14.70 KB, application/octet-stream)
2012-05-07 08:09 EDT, Vijaykumar Koppad
no flags Details
Log file the aux mount process. (21.82 KB, text/x-log)
2012-05-07 08:10 EDT, Vijaykumar Koppad
no flags Details
statedump of the hung client (4.30 MB, application/octet-stream)
2012-05-15 08:12 EDT, Raghavendra Bhat
no flags Details

  None (edit)
Description Vijaykumar Koppad 2012-05-07 08:08:32 EDT
Description of problem: In geo-replication session between master and a slave, some 60000 files of 10B were created on the master, those were synced on the slave. Later these files on the master were deleted, and started created different files, but the state of slave was stuck to the previous state ,means , the old file which were deleted on the master are not yet deleted on the slave , even after 2 days.
    From state dump of the aux mount process of the geo-rep , the quick read was hung.


Version-Release number of selected component (if applicable): 3.3.0qa38


How reproducible:Tried only once 


Steps to Reproduce:
1.Start a geo-rep session between master and slave ,master(dist-rep) ans slave(dist-stripe) 
2.Create 60000 of 10B file on the master and let it sync on the slave 
3.Delete the all files on the master and start creating many file on the master.
4. The new files created shouldn't sync on the slave.
  
Actual results:


Expected results:


Additional info:
Comment 1 Vijaykumar Koppad 2012-05-07 08:09:35 EDT
Created attachment 582635 [details]
Statedump of the aux mount process of the geo-rep session
Comment 2 Vijaykumar Koppad 2012-05-07 08:10:13 EDT
Created attachment 582636 [details]
Log file the aux mount process.
Comment 3 Raghavendra Bhat 2012-05-15 08:10:51 EDT
Even I hit the issue when I was running dbench and doing quota enable/disable in a loop and once disabled/enabled quick-read xlator also.

Statedump of the hung client process is attached.
Comment 4 Raghavendra Bhat 2012-05-15 08:12:48 EDT
Created attachment 584647 [details]
statedump of the hung client
Comment 5 Raghavendra G 2012-05-23 14:10:52 EDT
The patch has gone in and for some reason its not reflected in the comments here. Hence moving bug to QA.
Comment 6 Vijaykumar Koppad 2012-06-08 03:30:14 EDT
While reproducing the issue i found another bug 827405 , and i was not able to reproduce the above bug.
Comment 7 Vijaykumar Koppad 2012-06-09 05:21:27 EDT
Although i got another bug while verifying this bug , i am moving to verified.

Note You need to log in before you can comment on or make changes to this bug.