Bug 819494 - ip.sh assigns IP address to "wrong" interface for host with multiple interfaces on same network
ip.sh assigns IP address to "wrong" interface for host with multiple interfac...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rgmanager (Show other bugs)
5.7
All Linux
low Severity medium
: rc
: 5.9
Assigned To: Ryan McCabe
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-07 08:14 EDT by Jonathan Barber
Modified: 2013-01-08 02:05 EST (History)
6 users (show)

See Also:
Fixed In Version: rgmanager-2.0.52-33.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 843049 (view as bug list)
Environment:
Last Closed: 2013-01-08 02:05:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix (1.98 KB, patch)
2012-07-12 16:49 EDT, Ryan McCabe
no flags Details | Diff
Fix committed to RHEL59 cluster.git (2.09 KB, patch)
2012-07-25 08:20 EDT, Ryan McCabe
no flags Details | Diff

  None (edit)
Description Jonathan Barber 2012-05-07 08:14:59 EDT
Description of problem:
When a host has two interfaces on the same IPv4 subnet, and a RHCS managed IP is configured on the same subnet, the RHCS IP is added to the first interface returned by the "ip" tool. However, I don't want it to use this interface.

This is an issue because I have two interfaces in the same IPv4 network - one is a resilient bond which I want to use to provide the service, the other is for management access for operations staff. RHCS is choosing the non-bonded interface.

I'd like the ability to configure which interface should be used.

Version-Release number of selected component (if applicable):
rgmanager-2.0.52-21.el5

How reproducible:
Always.

Steps to Reproduce:
1. Configure host with 2 interfaces on the same IPv4 network
2. Configure RHCS on this host with IP on the same network
3. Start RHCS
  
Actual results:
RHCS IP is on the "wrong" interface. 

Expected results:
To be able to configure RHCS to use the other interface.

Additional info:
Unfortunately, because of non-technical reasons, I can't place the two interfaces on different networks - so the current ip.sh behaviour is a problem for me.
Comment 1 RHEL Product and Program Management 2012-05-15 14:57:46 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 Ryan McCabe 2012-07-12 16:49:35 EDT
Created attachment 597904 [details]
fix
Comment 4 Ryan McCabe 2012-07-24 18:20:55 EDT
The parameter name has been changed from "interface" to "prefer_interface"
Comment 7 Ryan McCabe 2012-07-25 08:20:21 EDT
Created attachment 600291 [details]
Fix committed to RHEL59 cluster.git
Comment 11 errata-xmlrpc 2013-01-08 02:05:28 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0026.html

Note You need to log in before you can comment on or make changes to this bug.