Bug 819511 - [REST API] Service should provide the right list of gear profiles that a user can use to create an application
[REST API] Service should provide the right list of gear profiles that a user...
Status: CLOSED UPSTREAM
Product: OpenShift Origin
Classification: Red Hat
Component: Master (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Abhishek Gupta
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-07 09:07 EDT by Xavier Coulon
Modified: 2015-05-14 20:51 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-19 18:26:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xavier Coulon 2012-05-07 09:07:28 EDT
In its current implementation, the service provides a complete list of gear profiles in the 'ADD_APPLICATION' link from a given domain resource, but this list does not take into account the user's profile. 
In the JBoss Tools integration, we display that list into a combo, but we have no way to filter and restrict to the allowed values, which means that users can be tempted to pick a 'medium' or 'large' gear profile event if their account does not allow it, giving an error at creation.

Ideally, the service should only provide the client with a valid list of gear profiles.
Comment 1 Xavier Coulon 2012-05-07 09:17:51 EDT
Adding link to https://issues.jboss.org/browse/JBIDE-11790
Comment 2 Abhishek Gupta 2012-06-14 20:12:22 EDT
This seems like a duplicate of Bug 817170
Comment 3 Peter Ruan 2012-06-19 18:26:17 EDT
verfied in INT 

"valid_options": [

    "small",
    "medium"

],

Note You need to log in before you can comment on or make changes to this bug.