Bug 819532 - Upgrade db from 3.0 to 3.1 fails due to missing supported_engines
Upgrade db from 3.0 to 3.1 fails due to missing supported_engines
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-core (Show other bugs)
unspecified
x86_64 Linux
high Severity high
: ---
: 3.1
Assigned To: Eli Mesika
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-07 09:52 EDT by Alex Lourie
Modified: 2012-08-09 04:01 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-09 04:01:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Lourie 2012-05-07 09:52:43 EDT
Description of problem:
When upgrading from 3.0. the following error appears:

Creating views...
psql:create_views.sql:560: ERROR:  column vds_dynamic.supported_engines does not exist
LINE 20: ...orted_cluster_levels as supported_cluster_levels, vds_dynami...


Version-Release number of selected component (if applicable):
3.0

How reproducible:
Install RHEVM 3.0. Perform db upgrade to 3.1

Additional info:

The problem is in that the code that creates the column is currently resides in create_tables.sql, while it should be in one of the pre-upgrade functions.

WA is to add the following function call to the custom.sql in pre-upgrade folder:

select fn_db_add_column('vds_dynamic','supported_engines','varchar(40)');
Comment 1 Eli Mesika 2012-05-07 10:13:02 EDT
http://gerrit.ovirt.org/#change,4177
Comment 2 Itamar Heim 2012-08-09 04:01:05 EDT
closing ON_QA bugs as oVirt 3.1 was released:
http://www.ovirt.org/get-ovirt/

Note You need to log in before you can comment on or make changes to this bug.