Bug 819539 - rhel6.2 product promotion failed
rhel6.2 product promotion failed
Status: CLOSED WORKSFORME
Product: Pulp
Classification: Community
Component: user-experience (Show other bugs)
unspecified
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: Pradeep Kilambi
Preethi Thomas
:
Depends On: 818474
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-07 10:02 EDT by Pradeep Kilambi
Modified: 2013-09-09 12:32 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 818474
Environment:
Last Closed: 2012-05-17 08:46:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pradeep Kilambi 2012-05-07 10:02:29 EDT
+++ This bug was initially created as a clone of Bug #818474 +++

Description of problem:
I was trying to promote a rhel6.2 repo fro 'Library' --> 'test' env. And promotion get failed with following error in pulp.log:

-
 2012-05-03 06:51:08,947 26015:139798205392640: pulp.server.api.synchronizers:INFO: synchronizers:976 Working on 500/7079
2012-05-03 06:51:14,730 26015:139798205392640: pulp.server.api.synchronizers:INFO: synchronizers:976 Working on 1000/7079
2012-05-03 06:51:33,741 26015:139798205392640: pulp.server.api.synchronizers:INFO: synchronizers:976 Working on 1500/7079
2012-05-03 06:51:41,859 26015:139798205392640: pulp.server.api.synchronizers:INFO: synchronizers:976 Working on 2000/7079
2012-05-03 06:52:01,192 26015:139798205392640: pulp.server.tasking.task:ERROR: task:468 Task failed: Task 6a80a8e6-94bd-11e1-835d-525400dee447: _sync(sghai-test-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Linux_6_Server_RPMs_x86_64_6_2, synchronizer=<pulp.server.api.synchronizers.YumSynchronizer object at 0x7f2535e5b250>, skip={}, max_speed=None, threads=4, progress_callback=<bound method RepoSyncTask.progress_callback of <pulp.server.api.repo_sync_task.RepoSyncTask object at 0x7f2540937950>>)
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/pulp/server/tasking/task.py", line 414, in run
    result = self.callable(*self.args, **self.kwargs)
  File "/usr/lib/python2.6/site-packages/pulp/server/api/repo_sync.py", line 279, in _sync
    progress_callback, synchronizer, max_speed, threads)
  File "/usr/lib/python2.6/site-packages/pulp/server/api/repo_sync.py", line 362, in fetch_content
    progress_callback, max_speed, threads)
  File "/usr/lib/python2.6/site-packages/pulp/server/api/synchronizers.py", line 164, in sync
    max_speed=max_speed, threads=threads)
  File "/usr/lib/python2.6/site-packages/pulp/server/api/synchronizers.py", line 1307, in local
    blacklist_packages, progress_callback)
  File "/usr/lib/python2.6/site-packages/pulp/server/api/synchronizers.py", line 980, in _sync_rpms
    self._process_rpm(pkg, src_repo_dir, dst_repo_dir)
  File "/usr/lib/python2.6/site-packages/pulp/server/api/synchronizers.py", line 902, in _process_rpm
    shutil.copy(src_pkg_path, dst_pkg_path)
  File "/usr/lib64/python2.6/shutil.py", line 84, in copy
    copyfile(src, dst)
  File "/usr/lib64/python2.6/shutil.py", line 48, in copyfile
    raise Error("`%s` and `%s` are the same file" % (src, dst))
Error: `/var/lib/pulp//repos/sghai/Library/content/dist/rhel/server/6/6.2/x86_64/os/Packages/kdelibs3-devel-3.5.10-24.el6_1.1.i686.rpm` and `/var/lib/pulp//packages/kdelibs3-devel/3.5.10/24.el6_1.1/i686/4f4d991b1de0c554d776edea54b222ef472520b15a3b72652879beb433931cda/kdelibs3-devel-3.5.10-24.el6_1.1.i686.rpm` are the same file


Version-Release number of selected component (if applicable):
rc1 
pulp-1.0.4-1.el6.noarch
katello-0.1.311-1.el6_2.noarch

How reproducible:
tried once

Steps to Reproduce:
1. Sync rhel6.2 product
2. create a changeset 
3. add product to promote to next env
  
Actual results:
File "/usr/lib64/python2.6/shutil.py", line 48, in copyfile
    raise Error("`%s` and `%s` are the same file" % (src, dst))
Error: `/var/lib/pulp//repos/sghai/Library/content/dist/rhel/server/6/6.2/x86_64/os/Packages/kdelibs3-devel-3.5.10-24.el6_1.1.i686.rpm` and `/var/lib/pulp//packages/kdelibs3-devel/3.5.10/24.el6_1.1/i686/4f4d991b1de0c554d776edea54b222ef472520b15a3b72652879beb433931cda/kdelibs3-devel-3.5.10-24.el6_1.1.i686.rpm` are the same file

Expected results:
promotion should succeed

Additional info:  No error in production.log

--- Additional comment from sghai@redhat.com on 2012-05-03 04:04:06 EDT ---

Created attachment 581796 [details]
delayed _job.log

--- Additional comment from sghai@redhat.com on 2012-05-03 04:34:10 EDT ---

Created attachment 581803 [details]
Katello-debug logs

--- Additional comment from jlaska@redhat.com on 2012-05-03 11:52:52 EDT ---

I'm not experiencing this problem on my katello setup.  That doesn't mean it's not a bug, just adding some data.

Is it possible that you are re-using /var/lib/pulp from previous installations?

# ls /var/lib/pulp//repos/redhat/Library/content/dist/rhel/server/6/6.2/x86_64/os/Packages/kdelibs3-devel-3.5.10-24.el6_1.1.i686.rpm /var/lib/pulp//packages/kdelibs3-devel/3.5.10/24.el6_1.1/i686/4f4d991b1de0c554d776edea54b222ef472520b15a3b72652879beb433931cda/kdelibs3-devel-3.5.10-24.el6_1.1.i686.rpm -l
-rw-r--r--. 1 apache apache 2087488 May  1 19:33 /var/lib/pulp//packages/kdelibs3-devel/3.5.10/24.el6_1.1/i686/4f4d991b1de0c554d776edea54b222ef472520b15a3b72652879beb433931cda/kdelibs3-devel-3.5.10-24.el6_1.1.i686.rpm
lrwxrwxrwx. 1 apache apache     189 May  1 20:20 /var/lib/pulp//repos/redhat/Library/content/dist/rhel/server/6/6.2/x86_64/os/Packages/kdelibs3-devel-3.5.10-24.el6_1.1.i686.rpm -> ../../../../../../../../../../../../packages/kdelibs3-devel/3.5.10/24.el6_1.1/i686/4f4d991b1de0c554d776edea54b222ef472520b15a3b72652879beb433931cda/kdelibs3-devel-3.5.10-24.el6_1.1.i686.rpm

--- Additional comment from mmccune@redhat.com on 2012-05-03 11:53:58 EDT ---

can you instead just attach the output of:

/usr/share/katello/script/katello-debug

vs the individual logs?

also:

Was this system preserved in some way between installs of Katello?  Did /var/lib/pulp exist between versions of CFSE or was it entirely fresh install of the OS?

There are known problems if you preserve /var/lib/pulp between versions of CFSE and we recommend each install does not preserve the files within that directory tree.

--- Additional comment from sghai@redhat.com on 2012-05-03 12:14:54 EDT ---

(In reply to comment #3)
> I'm not experiencing this problem on my katello setup.  That doesn't mean it's
> not a bug, just adding some data.
> 
> Is it possible that you are re-using /var/lib/pulp from previous installations?
> 
I'm using fresh setup and directly synced the contents from CDN. I synced rhel6.2 rpm repo and rhel6.2 optional rpm repo of 64 bit arch. so no re-usage of /var/lib/pulp from previous installations.

--- Additional comment from sghai@redhat.com on 2012-05-03 12:23:05 EDT ---

(In reply to comment #4)
> can you instead just attach the output of:
> 
> /usr/share/katello/script/katello-debug
> 
> vs the individual logs?
> 
> also:
> 
> Was this system preserved in some way between installs of Katello?  Did
> /var/lib/pulp exist between versions of CFSE or was it entirely fresh install
> of the OS?
> 
> There are known problems if you preserve /var/lib/pulp between versions of CFSE
> and we recommend each install does not preserve the files within that directory
> tree.

log files are attached in tar form, generated from katello-debug. And I installed CFSE after installing fresh OS. So its completely fresh setup.

I'm sure this is a random issue as product promotion working for others on rc1 and even for me on earlier builds.

--- Additional comment from pkilambi@redhat.com on 2012-05-03 14:24:50 EDT ---

I tried reproducing this on my local pulp server and both my syncs and promotions went ok without any errors. If you do have a clean system like you said, this might be some race condition we're running into due to timing. I'll keep poking around to reproduce, but this issue doesnt seem like a blocker yet.

Note You need to log in before you can comment on or make changes to this bug.