This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 819541 - SELinux is preventing /usr/lib/nspluginwrapper/npviewer.bin from 'open' accesses on the file C:\nppdf32Log\debuglog.txt.
SELinux is preventing /usr/lib/nspluginwrapper/npviewer.bin from 'open' acces...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:536d670db3cb21869abeea3133d...
:
: 949170 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-07 10:08 EDT by penguin283
Modified: 2013-04-08 05:09 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-08 11:18:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description penguin283 2012-05-07 10:08:41 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.4-4.fc17.x86_64
time:           Mon 07 May 2012 10:07:16 AM EDT

description:
:SELinux is preventing /usr/lib/nspluginwrapper/npviewer.bin from 'open' accesses on the file C:\nppdf32Log\debuglog.txt.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that npviewer.bin should be allowed open access on the C:\nppdf32Log\debuglog.txt file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep npviewer.bin /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
:                              0.c1023
:Target Context                unconfined_u:object_r:user_home_dir_t:s0
:Target Objects                C:\nppdf32Log\debuglog.txt [ file ]
:Source                        npviewer.bin
:Source Path                   /usr/lib/nspluginwrapper/npviewer.bin
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           nspluginwrapper-1.4.4-7.fc17.i686
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-121.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.4-4.fc17.x86_64 #1
:                              SMP Fri May 4 17:25:07 UTC 2012 x86_64 x86_64
:Alert Count                   10
:First Seen                    Mon 07 May 2012 06:24:38 AM EDT
:Last Seen                     Mon 07 May 2012 10:05:36 AM EDT
:Local ID                      d27ae911-4893-4fc2-850a-9e52e0c3473c
:
:Raw Audit Messages
:type=AVC msg=audit(1336399536.23:77): avc:  denied  { open } for  pid=1653 comm="npviewer.bin" name="C:\nppdf32Log\debuglog.txt" dev="sda5" ino=134075 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_dir_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1336399536.23:77): arch=i386 syscall=fstat per=8 success=no exit=EACCES a0=f777632a a1=441 a2=1b6 a3=90a5208 items=0 ppid=1652 pid=1653 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=2 comm=npviewer.bin exe=/usr/lib/nspluginwrapper/npviewer.bin subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)
:
:Hash: npviewer.bin,mozilla_plugin_t,user_home_dir_t,file,open
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 penguin283 2012-05-07 10:31:02 EDT
Happens everytime Firefox starts. 
Tried  # grep npviewer.bin /var/log/audit/audit.log | audit2allow -M mypol
       # semodule -i mypol.pp
several times.
Comment 2 Daniel Walsh 2012-05-07 10:43:34 EDT
Where is C:\nppdf32Log\debuglog.txt located?

Have you tried to run restorecon on it?
Comment 3 penguin283 2012-05-07 11:36:45 EDT
As far as I can tell there is no C:\nppdf32Log\debuglog.txt which may be part of the problem. Never tried restorecon, does anything needed to be added to it?
Comment 4 Daniel Walsh 2012-05-07 15:08:34 EDT
It looks like you have some kind of wacky plugin which is attempting to download some Windows file into your homedir.  Probably not something you want.  Any idea what nppdf32log is?

We are not allowing mozilla_plugin_t to create arbitrary data in your homedir, which is what this is trying to do.
Comment 5 penguin283 2012-05-08 07:34:26 EDT
Disabled all plugins, alert still happened

Removed nspluginwrapper.i686 and alerts stopped.
Installed nspluginwrapper.x86_64, no more alerts yet with all plugins enabled. Thanks for the help. Richard
Comment 6 Daniel Walsh 2012-05-08 11:18:26 EDT
Ok if it happens again, reopen the bug.  Whatever was happening SELinux was blocking and that very well good have been a good thing.
Comment 7 Jim Perrin 2012-05-24 15:36:43 EDT
I'm seeing this as well, and it's adobe's acrobat reader browser plugin that causes this to happen. it also requires nspluginwrapper.i686
Comment 8 Daniel Walsh 2012-05-24 19:34:13 EDT
Probably need to open a bug with Adobe, to tell that Fedora does not have a directory,C:\nppdf32Log\
Comment 9 Miroslav Grepl 2013-04-08 05:09:47 EDT
*** Bug 949170 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.