Bug 819551 - kawa: Please migrate from tomcat6 to tomcat7
kawa: Please migrate from tomcat6 to tomcat7
Status: CLOSED DUPLICATE of bug 1106994
Product: Fedora
Classification: Fedora
Component: kawa (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Meng
Fedora Extras Quality Assurance
Depends On:
Blocks: NoTomcat6 1106994
  Show dependency treegraph
Reported: 2012-05-07 10:17 EDT by Mikolaj Izdebski
Modified: 2014-06-19 02:59 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2014-06-19 02:59:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Mikolaj Izdebski 2012-05-07 10:17:17 EDT
We want to transition from tomcat6 to tomcat7 in Fedora. By depending on tomcat6 kawa it is successfully blocking the mentioned transition.

The following is the list of kawa dependencies affecting the transition (the list is not guarranteed to be complete):
   Requires:      servlet25
   BuildRequires: servlet25

Pleasee update kawa to use tomcat7 instead of tomcat6. Thank you.
Comment 1 Fedora End Of Life 2013-04-03 14:15:06 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 19 development cycle.
Changing version to '19'.

(As we did not run this process for some time, it could affect also pre-Fedora 19 development
cycle bugs. We are very sorry. It will help us with cleanup during Fedora 19 End Of Life. Thank you.)

More information and reason for this action is here:
Comment 2 bbzsz 2013-04-26 09:33:26 EDT
This affects me too. Trying to install kawa on a fresh Fedora 19 alpha install gives me:

--> Running transaction check
---> Package kawa.i686 1:1.11-5.fc19 will be installed
--> Processing Dependency: servlet25 for package: 1:kawa-1.11-5.fc19.i686
--> Finished Dependency Resolution
Error: Package: 1:kawa-1.11-5.fc19.i686 (fedora)
           Requires: servlet25
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Comment 3 Fedora Admin XMLRPC Client 2013-05-07 12:23:08 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Christopher Meng 2013-05-13 06:00:31 EDT
I'll have a look later.

And I also welcome your help!
Comment 5 Mikolaj Izdebski 2013-05-13 06:36:12 EDT
The requires servlet25 correspond to Tomcat 6, which is not available in Fedora. You should migrate to using "servlet3" instead (package tomcat-servlet-3.0-api).

In the best case there will be no other changes to kawa required. Unfortunately servlet 2.5 and 3.0 APIs are not entirely compatible, so you may have to patch source code to support newer version of the API. You can find the specification and migration guides in the Internet.
Comment 6 Christopher Meng 2014-06-19 02:59:09 EDT

*** This bug has been marked as a duplicate of bug 1106994 ***

Note You need to log in before you can comment on or make changes to this bug.