Bug 819572 - jBPM ant deploy task returns 0 rc if pingServer() fails
jBPM ant deploy task returns 0 rc if pingServer() fails
Status: CLOSED WONTFIX
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: JBPM - within SOA (Show other bugs)
5.2.0 GA
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Marco Rietveld
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-07 11:01 EDT by Rick Wagner
Modified: 2016-09-20 01:04 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
If a jBPM3 process is deployed using the ant task and the server cannot be reached, a value of "0" will be returned instead of an error message. If you are trying to connect to a server and receive this value, check to make sure that the server is available before redeploying.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-25 08:36:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBPM-3653 Major Closed jBPM ant deploy task returns 0 rc if pingServer() fails 2014-09-25 08:50:18 EDT

  None (edit)
Description Rick Wagner 2012-05-07 11:01:01 EDT
Description of problem:
A customer has noted that the ant task used to deploy jBPM3 processes will return '0' (no error) if the server it's trying to reach is unavailable.  It seems more proper to return something other than 0, indicating an error.


Version-Release number of selected component (if applicable):
SOA-P 5.2

How reproducible:
Deploy a process, point to an imaginary server, check $?


Additional info:
Please contact GSS if questions arise.  Thank you.
Comment 1 Rick Wagner 2012-05-07 11:02:15 EDT
It looks as if a change to this code might bring the desired results (if pingServer() fails, then throw an Exception):

public void execute()
                throws BuildException
            {
                try
                {
                    if(pingServerOK())
                    {
                       ...
                    }
                }
                catch(Exception e)
                {
                    throw new BuildException((new StringBuilder()).append("couldn't deploy process archives : ").append(e.getMessage()).toString(), e);
                }
            }
Comment 2 Rick Wagner 2012-05-07 11:12:39 EDT
GSS prioritizes this 'medium'.  There is a customer that desires the change, but it is not a production-stopping issue.  If time is available, please consider implementing this small and isolated change in SOA-P 5.3. 

Thanks,

Rick
Comment 3 Rick Wagner 2012-05-31 15:11:09 EDT
Blocker-lite.  If we don't have time, we can un-blocker this one.
Comment 5 David Le Sage 2012-06-11 23:50:07 EDT
Sorry - clicked wrong flag.
Comment 6 Suz 2012-06-12 00:08:29 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
If a jBPM3 process is deployed using the ant task and the server cannot be reached, a value of "0" will be returned instead of an error message. If you are trying to connect to a server and receive this value, check to make sure that the server is available before redeploying.
Comment 7 Marco Rietveld 2014-09-25 08:36:12 EDT
Closing as WONTFIX since no development (or bugfixing) is being done on jBPM 3.
Comment 8 JBoss JIRA Server 2014-09-25 08:50:18 EDT
Marco Rietveld <marco.rietveld@redhat.com> updated the status of jira JBPM-3653 to Closed

Note You need to log in before you can comment on or make changes to this bug.