Bug 81962 - Default upgrade-path of up2date errata doesn't work out-of-the-box w/ 7.1
Default upgrade-path of up2date errata doesn't work out-of-the-box w/ 7.1
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-15 15:37 EST by Glen A. Foster
Modified: 2007-04-18 12:50 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-24 19:47:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Glen A. Foster 2003-01-15 15:37:08 EST
Caveat: I know 7.1 is considered _ancient_.  I am trying to complete a
project that requires using 7.1 -- we (HP) are testing a new BIOS version
on a box that originally shipped in the 7.1 timeframe.  Part of our test
is to verify that 7.1 + all current errata work the same before and after
the BIOS upgrade.

Description of problem: Using "up2date" to obtain all 7.1 errata packages
no longer works with the advent of the up2date-2.8.39-1.7.1 errata.  You
simply can't do it.

Version-Release number of selected component (if applicable):
# rpm -q up2date
up2date-2.8.39-1.7.1

How reproducible: 100% (always)

Steps to Reproduce:
1. Everything install of 7.1 "seawolf" on i386 box behind a corporate firewall
2. get errata packages for rhn_register, rhn_register-gnome and upgrade them
   ==> note you also need python-xmlrpc, so get it from ftp site, too
3. upgrade these 3 packages (this works) 
4. enter your proxy info into /etc/sysconfig/rhn/rhn_register
5. register system via rhn_register (this works)
6. run "up2date" to see what new packages are available
   ==> notice the failure at up2date startup about 'message not found'
7. obtain up2date and up2date-gnome errata packages and upgrade them
   ==> note you need mkinitrd, filesystem, and python-popt as well, so get them
8. obtain missing packages obtained in (7)
9. upgrade up2date*, mkinitrd, filesystem, and python-popt (this works)
10. run "up2date" again to see what new packages are available
   ==> note the error message:

Error communicating with server.  The message was:
Connection refused.

... sounds like a proxy-setting problem.  Examining /etc/sysconfig/rhn/up2date 
shows the proxy settings from rhn_register weren't migrated.

11. edit /etc/sysconfig/rhn/up2date and add the same proxy settings as was 
entered in step (4) above
12. run "up2date" again to see what new packages are available
13. note the error message seen in (14) still exists.
    
Actual results: no packages upgraded

Expected results: up2date should work with this strategy

Additional info: again, I know 7.1 is very old.  It's a project requirement for 
this particular exercise... and the website says 7.1 is supported through 
December, 2003.
Comment 1 Glen A. Foster 2003-01-15 15:37:49 EST
Adding Jay to the Cc: list since I reported this to him over the phone.
Comment 2 Adrian Likins 2003-01-15 15:47:08 EST
connection refused almost always indicates a network problem
of some sort.

There doesnt seem to be any problems on the live site, with
7.1 or other releases as best I can tell. 

I'd doublecheck the network. Make sure you can reach
https://rhn.redhat.com via a web browser is a good
fist check.
Comment 3 Glen A. Foster 2003-01-15 15:54:30 EST
I'm able to connect to https://rhn.redhat.com just fine.  Plus, the settings 
worked perfectly to get rhn_register to work... 
Comment 4 Glen A. Foster 2003-01-24 16:54:08 EST
I'm not the only one @ HP seeing this.  Is there any development on this?  The 
errata packages avialable on the ftp site do NOT have all the appropriate 
dependencies and I was really hoping to get the right set of packages from RHN.
Comment 5 Adrian Likins 2003-01-24 17:21:37 EST
>I'm not the only one @ HP seeing this. 

Could be networking issues then...

> Is there any development on this?
Not a lot. This is a low priority at the moment. I
haven't seen any other reports of it. 

> The  errata packages avialable on the ftp site do NOT have all the appropriate
 >dependencies
What packages don't have approriate deps? All the
packages in RHN should be on the ftp site. 



up2date and rhn_register tend to use the same
network code. Can you attach /etc/sysconfig/rhn/up2date
(scrubbing any proxy user/passwd as neccesary). 

Comment 6 Glen A. Foster 2003-01-24 19:47:12 EST
Apparently there _was_ a networking issue that has been resolved.  I am now able
to retrieve RPMs via the 7.1 RHN channel where I was previously not able to.

As for which RPMs are not quite right on the ftp site:

(1) Do a fresh 7.1 everything install
(2) Fetch all RPMs from the 7.1/{i386,i686,noarch} directories
(3) Trim the unneeded RPMs (e.g., remove i386 glibc and older RPM versions of
kernel and other duplicately-named RPMs
(4) Install the kernel RPMs
(5) Upgrade all the rest of the un-installed or un-upgraded RPMs

... I got error messages for apache and kernel-utils just for starters...

Note You need to log in before you can comment on or make changes to this bug.