Bug 819660 - livemedia-creator displays ncurses screen and dialogs
livemedia-creator displays ncurses screen and dialogs
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
17
arm Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-07 17:27 EDT by D. Marlin
Modified: 2012-06-04 18:58 EDT (History)
11 users (show)

See Also:
Fixed In Version: lorax-17.24-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-04 18:58:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Trim Slice livemedia-creator kickstart config file (2.02 KB, text/plain)
2012-05-07 17:29 EDT, D. Marlin
no flags Details

  None (edit)
Description D. Marlin 2012-05-07 17:27:44 EDT
Description of problem:

I have been using the following command:

 livemedia-creator \
   --make-disk --no-virt --image-only --keep-image \
   --ks=/root/f17-TS-test.ks

to create a disk install image. The output has always been in the form of text messages (log) displayed to the terminal window. I updated lorax and anaconda to the latest F17 versions (anaconda-17.24-1.fc17, lorax-17.17-1.fc17).  Previously I was running anaconda-17.21-1.fc17 and lorax-17.15-1.fc17.

Now when I run the same command I do not see the expected text log, and after some time passes I see a blue screen with ncurses-type dialogs.


Version-Release number of selected component (if applicable):

anaconda-17.24-1.fc17
lorax-17.17-1.fc17


How reproducible:

Always


Steps to Reproduce:
1.  log into an ARM host as root
2.  run the liveimage-creator command shown in description above

  
Actual results:

A blue screen is displayed showing:

---------------------------------------------------------
Welcome to anaconda for armv7l


       +----------------------- Post Installation ------------------------+
       |                                                                  |
       |          Performing post-installation configuration              |
       |                                                                  |
       + -----------------------------------------------------------------+



<Tab>/<Alt-Tab> between elements | <Space> selects | <F12> next screen
---------------------------------------------------------


Expected results:

Normal console-type text log output.


Additional info:

This is on a system with a serial console only (no display, keyboard, or mouse).

The process does complete and the disk image appears to be correct.  Only the terminal display seems to be affected.

This may affect other archs as well, but I have not tested to verify.
Comment 1 D. Marlin 2012-05-07 17:29:07 EDT
Created attachment 582789 [details]
Trim Slice livemedia-creator kickstart config file
Comment 2 D. Marlin 2012-05-11 09:59:49 EDT
From IRC:
"<bcl> I expect that 819660 is because you have 'text' set in the kickstart. that isn't needed since livemedia-creator uses the new script mode."

I updated to anaconda-17.26 and removed 'text' from the kickstart file.  This run completed with the expected text (log) messages and no ncurses screen or dialogs.  It looks good to me.

Question: Since 'text' causes problems when included in a kickstart file used by livemedia-creator, would it be difficult to have livemedia-creator remove or ignore the 'text' option, rather than produce unexpected behavior?
Comment 3 Brian Lane 2012-05-11 16:40:48 EDT
I'd rather not modify the kickstart. It is expected to be setup correctly for use with LMC. I could add an error if it is present though.
Comment 4 Brian Lane 2012-05-15 16:50:43 EDT
I've added a check for text, cmdline, graphical which will be in the next lorax build.

Note You need to log in before you can comment on or make changes to this bug.