Bug 819677 - XDR decoding fails after upgrading from 3.2
XDR decoding fails after upgrading from 3.2
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: rpc (Show other bugs)
3.3-beta
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Divya
Raghavendra Bhat
:
Depends On:
Blocks: 817967
  Show dependency treegraph
 
Reported: 2012-05-07 20:12 EDT by Joe Julian
Modified: 2015-12-01 11:45 EST (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:13:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: DP
CRM:
Verified Versions: release-3.3 branch git head: 281c79c3766ca6a912e419d0cde24d1b8c457cbe
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Julian 2012-05-07 20:12:20 EDT
An IRC user reported being unable to connect to his volumes after upgrading from 2.3.6 to 3.3beta3. glusterd was also unable to communicate with glusterfsd when he tried to stop the volume using the cli.

[2012-05-07 23:52:19.152921] E [client-handshake.c:1821:client_dump_version_cbk] 0-testlabs-project-client-1: XDR decoding failed

He had not killed his bricks. Killing the bricks and restarting glusterd solved that problem.

I was under the impression that the RPC was supposed to handle trans-version interfacing to prevent this problem. 

Worst-case, the glusterfsd instances will need to be killed during the upgrade process.
Comment 1 Joe Julian 2012-05-07 20:14:10 EDT
Typo:
2.3.6 should have been 3.2.6
Comment 2 Amar Tumballi 2012-05-10 02:25:01 EDT
Joe, Because of few changes which are not compatible with 3.2.x branch and 3.3.x branch, we decided when the upgrade happens from 3.2.x to 3.3.0 branch, this will be a disruptive behavior.

Will mark it for documentation bug. At this point in time, it is not feasible to do code changes to support this behavior.
Comment 3 Divya 2012-05-18 06:39:32 EDT
In "Compatibility" section of Release Notes, we have already mentioned "Release 3.3 of GlusterFS is not compatible with 2.0.x, 3.0.x, 3.1.x, and 3.2.x releases of GlusterFS".
Comment 4 Raghavendra Bhat 2012-06-04 06:55:19 EDT
Release 3.3 of GlusterFS is not compatible with 2.0.x, 3.0.x, 3.1.x, and 3.2.x releases of GlusterFS.

It has been mentioned in the glusterfs-3.3 release notes.

Note You need to log in before you can comment on or make changes to this bug.