Bug 819698 - Stop fcoe-target daemon cannot remove all fcoe-target session.
Summary: Stop fcoe-target daemon cannot remove all fcoe-target session.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: fcoe-target-utils
Version: 6.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Andy Grover
QA Contact: Gris Ge
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-05-08 02:14 UTC by Gris Ge
Modified: 2013-02-21 10:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-21 10:48:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0457 normal SHIPPED_LIVE fcoe-target-utils bug fix and enhancement update 2013-02-20 21:07:34 UTC

Description Gris Ge 2012-05-08 02:14:19 UTC
Description of problem:

After fcoe-target daemon stop, all fcoe-target session is still running.

/etc/init.d/fcoe-taget
====
112 stop()
113 {
114     echo "Stopping $prog: "
115
116     echo -n "   Unloading $prog modules... "
117     stop_ccsd
118     if [ $? -eq 0 ]
119     then
120 >---echo "done"
121     else
122 >---echo "failed"
123 >---return 1
124     
====

stop_ccsd() didn't exist. You must mean "unload_modules()" function.

Version-Release number of selected component (if applicable):

fcoe-target-utils-2.0rc1.fb10-4.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. Start FCoE target session.
2. Stop fcoe-target daemon.
3. Check wether fcoe-taget session got removed.
  
Actual results:
all target session still exist.

Expected results:
all target session got removed.

Additional info:
No sure whether change "stop_ccsd()" to "unload_modules()" fix the problem or not. Please be informed, this bug is aim to make sure all fcoe-target session got disabled when daemon stop.

BTW: 
1. the format of /etc/target/saveconfig.json is not user-friently.
2. the way of targetcli force us to use "expect" or similar tool for scripting.
3. scsi-target-utils set a very good example for how a target severs should be.

Comment 1 Gris Ge 2012-05-08 02:18:45 UTC
please ignore the BTW_2, I notice targetcli support non-interactive mode.

Comment 2 Andy Grover 2012-05-08 23:29:17 UTC

*** This bug has been marked as a duplicate of bug 815981 ***

Comment 3 Gris Ge 2012-05-16 09:20:50 UTC
Reopen,

Stop daemon still failed like these:
=====
[root@storageqe-14 ~]#  /etc/init.d/fcoe-target stop
   Deactivating FCoE Target... done
   Unloading FCoE Target modules... failed
ERROR: Module target_core_mod is in use by tcm_fc
                                                           [FAILED]
=====
[root@storageqe-14 ~]# lsmod|grep fc
tcm_fc                 27313  1
libfc                 108727  1 tcm_fc
target_core_mod       343420  2 tcm_fc
scsi_transport_fc      55235  2 libfc,bfa
scsi_tgt               12173  1 scsi_transport_fc
=====


If I stop daemon again, I got this:
=====
[root@storageqe-14 ~]#  /etc/init.d/fcoe-target stop
   Deactivating FCoE Target... done
   Unloading FCoE Target modules... failed
ERROR: Module target_core_pscsi does not exist in /proc/modules
                                                           [FAILED]
=====

Please use "modporbe -qra foo_a foo_b" instead of rmmod.


Decrease priority and request fix in RHEL 6.4 as QE resource limit.

If we found any other urgent bug for fcoe-target, we can treat this bug as exception.

Comment 6 Gris Ge 2013-01-25 03:24:42 UTC
VERIFY.
fcoe-target-utils-2.0rc1.fb16-3.el6.noarch clear all fcoe-target on daemon stop.

Comment 8 errata-xmlrpc 2013-02-21 10:48:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0457.html


Note You need to log in before you can comment on or make changes to this bug.