Bug 819709 - Groups dropped when moving bugs between products
Groups dropped when moving bugs between products
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Creating/Changing Bugs (Show other bugs)
3.6
Unspecified Unspecified
high Severity urgent (vote)
: ---
: ---
Assigned To: Simon Green
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-07 23:12 EDT by Simon Green
Modified: 2014-10-12 18:47 EDT (History)
2 users (show)

See Also:
Fixed In Version: 4.2.2-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-30 19:39:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simon Green 2012-05-07 23:12:17 EDT
Description of problem:
Mass moving bugs between products seems to drop all group privileges.

Version-Release number of selected component (if applicable):
3.6

How reproducible:
Always?

Steps to Reproduce:
1. Select a group of bugs, some with group privileges
2. Move them to a different product, choosing the "Don't change this group restriction" option.
  
Actual results:
Watch the group privileges disappear.


Expected results:
Group privileges should remain

Additional info:
This occurred when processing RT 152195.

  -- simon
Comment 1 Simon Green 2012-06-27 23:40:16 EDT
I have found out the cause of this, and have filled a bug upstream since it affects them. If they mark it as WONTFIX, then I'll carry the change locally since it definitely doesn't work as I would expect it to.

  -- simon
Comment 2 Simon Green 2012-06-28 02:21:56 EDT
So I proposed two options upstream, but have found flaws in both of them. I've proposed a third solution (bigger patch, but better solution IMO), but we are going to wait until LpSolit and dkl get online so they can add their 2ยข worth before I start writing a patch.

  -- simon
Comment 3 Simon Green 2012-06-28 23:33:47 EDT
It seems my third idea is the best one. I've written a patch for it and submitted it upstream. Will wait for them to approve it before putting it in our code base.
Comment 5 Simon Green 2012-07-05 19:33:13 EDT
Since this won't make the cut before 4.2.1-3 is released, I'm marking this as CLOSED/UPSTREAM. When (if) they include it in Bugzilla 4.2, we inherit the code that way.

  -- simon
Comment 6 Simon Green 2012-07-26 01:40:01 EDT
Upstream approved the patch, but rejected it for inclusion upstream. Therefore we will carry this change locally. Changed the estimate to one hour more to get the patch and make the recommended changes.

  -- simon

Note You need to log in before you can comment on or make changes to this bug.