Bug 819711 - the thin pool metadata not be placed on different PVs from the pool data
the thin pool metadata not be placed on different PVs from the pool data
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
17
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: LVM and device-mapper development team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-07 23:21 EDT by Xiaowei Li
Modified: 2015-01-26 19:10 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-07 10:13:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lvcreate.log (203.41 KB, application/octet-stream)
2012-05-09 02:31 EDT, Xiaowei Li
no flags Details
lvm.conf (32.33 KB, application/octet-stream)
2012-05-09 02:31 EDT, Xiaowei Li
no flags Details

  None (edit)
Description Xiaowei Li 2012-05-07 23:21:39 EDT
Description of problem:
the thin pool metadata not be placed on different PVs from the pool data

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.set thin_pool_metadata_require_separate_pvs = 1 in /etc/lvm/lvm.conf
2.create vg with 4 PVs
3.lvcreate -i4 -T -V 100m -l1 -n lv11 tsvg/pool1
  
Actual results:
pool1 and lv11 are created successfully and include the same PV : /dev/loop3
[root@laker T2]# lvs -a -olv_name,pool_lv,devices tsvg
lvs  LV            Pool  Devices                                                
lvs  lv11          pool1                                                        
lvs  pool1               pool1_tdata(0)                                         
lvs  [pool1_tdata]       /dev/loop0(0),/dev/loop1(0),/dev/loop2(0),/dev/loop3(0)
lvs  [pool1_tmeta]       /dev/loop3(1) 


Expected results:
should throw an error that fail to create the thin pool due to insufficient PVs to place the the pool metadata on different PVs from the pool data


Additional info:
Comment 1 Alasdair Kergon 2012-05-08 08:11:15 EDT
When reporting lvm bugs, please run the relevant command with -vvvv and attach the output.

So in this particular case, attach the output of:

lvcreate -vvvv -i4 -T -V 100m -l1 -n lv11 tsvg/pool1

That will reveal what is going wrong.
Comment 2 Alasdair Kergon 2012-05-08 08:59:37 EDT
I can't reproduce your problem, by the way:

  Not enough PVs with free space available for parallel allocation.
  Consider --alloc anywhere if desperate.
Comment 3 Xiaowei Li 2012-05-09 02:31:02 EDT
Created attachment 583149 [details]
lvcreate.log
Comment 4 Xiaowei Li 2012-05-09 02:31:31 EDT
Created attachment 583150 [details]
lvm.conf
Comment 5 Xiaowei Li 2012-05-09 02:38:01 EDT
(In reply to comment #1)
> When reporting lvm bugs, please run the relevant command with -vvvv and attach
> the output.
> 
> So in this particular case, attach the output of:
> 
> lvcreate -vvvv -i4 -T -V 100m -l1 -n lv11 tsvg/pool1
> 
> That will reveal what is going wrong.

reproduced it and attached the logs. If i have any misunderstanding for the parameter thin_pool_metadata_require_separate_pvs please let me know.
Comment 6 Alasdair Kergon 2012-05-09 07:07:35 EDT
The setting is in a section called 'allocation' in the lvm.conf file.
You need to uncomment two more lines.

allocation {
}
Comment 7 Alasdair Kergon 2012-05-09 07:09:10 EDT
(BTW The value of that setting was not getting logged in -vvvv - something I fixed upstream yesterday.)
Comment 8 Alasdair Kergon 2012-05-09 07:46:22 EDT
I've opened low-priority bug 820203 to report invalid lvm.conf entries.
Comment 9 Xiaowei Li 2012-05-10 10:32:59 EDT
(In reply to comment #6)
> The setting is in a section called 'allocation' in the lvm.conf file.
> You need to uncomment two more lines.
> 
> allocation {
> }

Thanks. It's my fault. 

One suggestion, uncomment the the section called 'allocation' even if all its' sub-items are commented. This can help the users to avoid the similar fault.

# allocation {
#>>>snip>>>
#}
Comment 10 Xiaowei Li 2012-05-10 10:34:00 EDT
(In reply to comment #9)
> (In reply to comment #6)
> > The setting is in a section called 'allocation' in the lvm.conf file.
> > You need to uncomment two more lines.
> > 
> > allocation {
> > }
> 
> Thanks. It's my fault. 
> 
> One suggestion, uncomment the the section called 'allocation' even if all its'
> sub-items are commented. This can help the users to avoid the similar fault.
> 
> # allocation {
> #>>>snip>>>
> #}

This suggestion is for the default lvm.conf

Note You need to log in before you can comment on or make changes to this bug.