Bug 819714 - [abrt] libcompizconfig: ccsCanDisablePlugin: access of NULL object signal 11 (SIGSEGV)
[abrt] libcompizconfig: ccsCanDisablePlugin: access of NULL object signal 11 ...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: libcompizconfig (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: leigh scott
Fedora Extras Quality Assurance
abrt_hash:d8605190467bdcb9cd1fdb2a063...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-07 23:24 EDT by arhi.smece
Modified: 2012-05-08 07:14 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-08 04:19:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: build_ids (4.36 KB, text/plain)
2012-05-07 23:24 EDT, arhi.smece
no flags Details
File: dso_list (10.75 KB, text/plain)
2012-05-07 23:24 EDT, arhi.smece
no flags Details
File: smolt_data (6.45 KB, text/plain)
2012-05-07 23:24 EDT, arhi.smece
no flags Details
File: maps (50.82 KB, text/plain)
2012-05-07 23:24 EDT, arhi.smece
no flags Details
File: backtrace (44.71 KB, text/plain)
2012-05-07 23:24 EDT, arhi.smece
no flags Details

  None (edit)
Description arhi.smece 2012-05-07 23:24:17 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        /usr/bin/python /usr/bin/ccsm
crash_function: ccsCanDisablePlugin
executable:     /usr/bin/python2.7
kernel:         3.3.4-3.fc16.x86_64
pid:            4954
pwd:            /home/arhimed
reason:         Process /usr/bin/python2.7 was killed by signal 11 (SIGSEGV)
time:           Mon 07 May 2012 07:22:41 PM CEST
uid:            1000
username:       arhimed
var_log_messages: May  7 19:22:41 localhost abrt[5036]: Saved core dump of pid 4954 (/usr/bin/python2.7) to /var/spool/abrt/ccpp-2012-05-07-19:22:41-4954 (20758528 bytes)

backtrace:      Text file, 45788 bytes
build_ids:      Text file, 4469 bytes
dso_list:       Text file, 11005 bytes
maps:           Text file, 52039 bytes
smolt_data:     Text file, 6603 bytes

environ:
:DREAL_TECHNO_NAME=/usr/lib64/alliance/etc/cmos.dreal
:XDG_VTNR=1
:MANPATH=:/usr/lib64/alliance/man:/usr/local/share/man:/usr/share/man:/usr/lib64/alliance/man
:VH_PATSFX=pat
:TPD_GLOBAL=/usr/share/toped/
:XDG_SESSION_ID=2
:SSH_AGENT_PID=2081
:HOSTNAME=vito
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GPG_AGENT_INFO=/home/arhimed/.gnupg/S.gpg-agent:2137:1
:GLADE_PIXMAP_PATH=:
:MBK_IN_PH=ap
:XDG_MENU_PREFIX=xfce-
:XSCH_PARAM_NAME=/usr/lib64/alliance/etc/xsch.par
:TERM=dumb
:SHELL=/bin/bash
:WISECONFIGDIR=/usr/share/wise2/
:LATEX_MK_DIR=/usr/share/latex-mk
:HISTSIZE=1000
:XDG_SESSION_COOKIE=2a625c89375f4a6a40eb38ce00000013-1336363757.735265-1260885126
:SGE_CELL=default
:NCARG_FONTCAPS=/usr/lib64/ncarg/fontcaps
:VH_MAXERR=10
:QTDIR=/usr/lib64/qt-3.3
:RDS_OUT=cif
:GNOME_KEYRING_CONTROL=/tmp/keyring-B5A2QV
:QTINC=/usr/lib64/qt-3.3/include
:XFSM_PARAM_NAME=/usr/lib64/alliance/etc/xfsm.par
:GRAAL_TECHNO_NAME=/usr/lib64/alliance/etc/cmos.graal
:ALLIANCE_TOP=/usr/lib64/alliance
:TPD_LOCAL=/home/arhimed
:IMSETTINGS_MODULE=none
:USER=arhimed
:LD_LIBRARY_PATH=/usr/lib64/alliance/lib
:GLADE_MODULE_PATH=:
:SSH_AUTH_SOCK=/tmp/ssh-mHpPHFei1940/agent.1940
:USERNAME=arhimed
:NCARG_GRAPHCAPS=/usr/lib64/ncarg/graphcaps
:XDG_CONFIG_DIRS=/etc/xdg
:MAIL=/var/spool/mail/arhimed
:DESKTOP_SESSION=xfce
:PATH=/usr/lib64/qt-3.3/bin:/usr/lib64/ccache:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/usr/lib64/alliance/bin:/usr/libexec/sdcc
:MBK_SCALE_X=100
:QT_IM_MODULE=xim
:MBK_CATAL_NAME=CATAL
:PWD=/home/arhimed
:NCARG_ROOT=/usr
:XMODIFIERS=@im=none
:KDE_IS_PRELINKED=1
:MBK_OUT_PH=ap
:LANG=en_US.UTF-8
:GNOME_KEYRING_PID=1934
:NCARG_DATABASE=/usr/lib64/ncarg/database
:MODULEPATH=/usr/share/Modules/modulefiles:/etc/modulefiles
:MBK_SPI_MODEL=/usr/lib64/alliance/etc/spimodel.cfg
:GENVIEW_TECHNO_NAME=/usr/lib64/alliance/etc/cmos.genview
:RDS_IN=cif
:SGE_ROOT=/usr/share/gridengine
:LOADEDMODULES=
:KDEDIRS=/usr
:MBK_OUT_LO=vst
:MBK_VSS=vss
:GDMSESSION=xfce
:NCARG_LIB=/usr/lib64/ncarg
:SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
:VH_BEHSFX=vbe
:HISTCONTROL=ignoredups
:NCARG_NCARG=/usr/share/ncarg
:SHLVL=2
:XDG_SEAT=seat0
:HOME=/home/arhimed
:MBK_C4_LIB=./cellsC4
:GDL_PATH=+/usr/share/gnudatalanguage
:MBK_VDD=vdd
:MBK_TARGET_LIB=/usr/lib64/alliance/cells/sxlib
:RDS_TECHNO_NAME=/usr/lib64/alliance/etc/cmos.rds
:VH_DLYSFX=dly
:LOGNAME=arhimed
:QTLIB=/usr/lib64/qt-3.3/lib
:CVS_RSH=ssh
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-l7Cc71vaQB,guid=c1db374a0f2b228bdcba1a0200000048
:XDG_DATA_DIRS=/usr/local/share:/usr/share
:MODULESHOME=/usr/share/Modules
:MBK_IN_LO=vst
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:MBK_WORK_LIB=.
:XPAT_PARAM_NAME=/usr/lib64/alliance/etc/xpat.par
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/arhimed
:GLADE_CATALOG_PATH=:
:LIBGLADE_MODULE_PATH=:
:ELP_TECHNO_NAME=/usr/lib64/alliance/etc/prol.elp
:MBK_CATA_LIB=.:/usr/lib64/alliance/cells/sxlib:/usr/lib64/alliance/cells/dp_sxlib:/usr/lib64/alliance/cells/rflib:/usr/lib64/alliance/cells/rf2lib:/usr/lib64/alliance/cells/ramlib:/usr/lib64/alliance/cells/romlib:/usr/lib64/alliance/cells/pxlib:/usr/lib64/alliance/cells/padlib
:CCACHE_HASHDIR=
:XAUTHORITY=/var/run/gdm/auth-for-arhimed-PgT9MT/database
:'module=() {  eval `/usr/bin/modulecmd bash $*`\n}'
:_=/usr/bin/xfce4-session
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/2146,unix/unix:/tmp/.ICE-unix/2146
:DISPLAY=:0.0
:DESKTOP_STARTUP_ID=xfce4-panel/ccsm/2151-7-vito_TIME47617191

xsession_errors:
:/usr/lib/python2.7/site-packages/ccm/Window.py:92: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
:/usr/lib/python2.7/site-packages/ccm/Window.py:95: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
:/usr/lib/python2.7/site-packages/ccm/Widgets.py:1570: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
:/usr/lib/python2.7/site-packages/ccm/Widgets.py:1575: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
:/usr/lib/python2.7/site-packages/ccm/Settings.py:1364: GtkWarning: Failed to set text from markup due to error parsing markup: Error on line 1: Entity did not end with a semicolon; most likely you used an ampersand character without intending to start an entity - escape ampersand as &
:/usr/lib/python2.7/site-packages/ccm/Window.py:93: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
:/usr/lib/python2.7/site-packages/ccm/Window.py:92: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
:/usr/lib/python2.7/site-packages/ccm/Window.py:95: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
:/usr/lib/python2.7/site-packages/ccm/Widgets.py:1570: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
:/usr/lib/python2.7/site-packages/ccm/Widgets.py:1575: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
:/usr/lib/python2.7/site-packages/ccm/Window.py:92: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
:/usr/lib/python2.7/site-packages/ccm/Window.py:95: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
:/usr/lib/python2.7/site-packages/ccm/Widgets.py:1570: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
:/usr/lib/python2.7/site-packages/ccm/Widgets.py:1575: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
:/usr/lib/python2.7/site-packages/ccm/Window.py:93: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
:/usr/lib/python2.7/site-packages/ccm/Window.py:92: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
:/usr/lib/python2.7/site-packages/ccm/Window.py:95: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
:/usr/lib/python2.7/site-packages/ccm/Widgets.py:1570: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
:/usr/lib/python2.7/site-packages/ccm/Widgets.py:1575: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
:/usr/lib/python2.7/site-packages/ccm/Window.py:93: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
Comment 1 arhi.smece 2012-05-07 23:24:21 EDT
Created attachment 582839 [details]
File: build_ids
Comment 2 arhi.smece 2012-05-07 23:24:23 EDT
Created attachment 582840 [details]
File: dso_list
Comment 3 arhi.smece 2012-05-07 23:24:25 EDT
Created attachment 582841 [details]
File: smolt_data
Comment 4 arhi.smece 2012-05-07 23:24:28 EDT
Created attachment 582842 [details]
File: maps
Comment 5 arhi.smece 2012-05-07 23:24:30 EDT
Created attachment 582843 [details]
File: backtrace
Comment 6 Thomas Spura 2012-05-08 02:47:02 EDT
Thanks for the bug report.

It looks like this is a bug in libcompizconfig:

   2445     CCSPluginConflict *conflict = NULL;
[snip]
   2468                 if (!conflict)
   2469                 {
   2470                     conflict->refCount = 1;
[snip]
   2477                 }

So when conflict is NULL, refCount is accessed??

No wonder, that this segfaults...

When the refCount line is moved down to the if (conflict) branch, this would be gone (that logic is used in line 2515 and below.)

Reassigning to libcompizconfig.
Comment 7 leigh scott 2012-05-08 04:19:45 EDT
Sorry I'm not fixing any compiz bugs.

Note You need to log in before you can comment on or make changes to this bug.