Bug 819716 - virsh cannot edit the guest xmlfile
virsh cannot edit the guest xmlfile
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
16
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Michal Privoznik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-07 23:35 EDT by Hongqing Yang
Modified: 2012-05-09 03:28 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-09 03:28:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Hongqing Yang 2012-05-07 23:35:47 EDT
Description of problem:

create a guest 'f17' with virt-manager, then edit with 
virsh edit f17, and add the following into the xml file.
<channel type='tcp'>
  <source mode='connect' host='127.0.0.1' service='6080'/>
  <target type='virtio' name='org.fedoraproject.anaconda.log.0'/>
</channel>

after save it and open the guest xml file, it does not exist.

Version-Release number of selected component (if applicable):
0.9.6

How reproducible:


Steps to Reproduce:
1. create a guest
2. edit with 'virsh edit <machine name>'
3. save the edit and exit
4. nothing changed
  
Actual results:


Expected results:


Additional info:
Comment 1 Hongqing Yang 2012-05-09 03:28:48 EDT
I updated my system and tried again today, it works now with the same libvirt version 0.9.6. So I will close it as it it not a bug.

Note You need to log in before you can comment on or make changes to this bug.