Bug 819781 - service ntpd start fails for systems with over 1024 IPs
service ntpd start fails for systems with over 1024 IPs
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ntp (Show other bugs)
6.2
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Miroslav Lichvar
qe-baseos-daemons
:
Depends On:
Blocks: 947775
  Show dependency treegraph
 
Reported: 2012-05-08 04:31 EDT by Anton
Modified: 2013-11-21 04:51 EST (History)
4 users (show)

See Also:
Fixed In Version: ntp-4.2.6p5-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 04:51:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anton 2012-05-08 04:31:17 EDT
Description of problem:
The "-L" option does not work. According to the ntp mailing list (which has core developers on it), this functionality was largely broken in the 4.2.4 branch (see http://www.mail-archive.com/questions@lists.ntp.org/msg18021.html). As such, it is impossible to start ntpd with over 1024 IPs. The interface/nic options are not available to 4.2.4 either so, unless I'm mistaken, the only solution is to install a non-supported version.

Version-Release number of selected component (if applicable):
ntp-4.2.4p8-2.el6.x86_64

How reproducible:
Completely.

Steps to Reproduce:
1. Add more than 1024 IPs to a system
2. Attempt to start ntpd
3.
  
Actual results:
...
May  3 09:40:57 MyHost ntpd[980]: Listening on interface #1005
eth1:132235, 10.132.235.1#123 Enabled
May  3 09:40:57 MyHost ntpd[980]: Listening on interface #1006
eth1:132236, 10.132.236.1#123 Enabled
May  3 09:40:57 MyHost ntpd[980]: Listening on interface #1007
eth1:132237, 10.132.237.1#123 Enabled
May  3 09:40:57 MyHost ntpd[980]: Too many sockets in use, FD_SETSIZE
1024 exceeded

Expected results:
...
May  8 10:27:25 HostOne ntpd[14529]: Listening on interface #27 eth0:120, 1.1.1.1#123 Enabled
May  8 10:27:25 HostOne ntpd[14529]: Listening on interface #28 eth1, 172.16.243.1#123 Enabled
May  8 10:27:25 HostOne ntpd[14529]: Listening on interface #29 eth1:0, 172.16.243.2#123 Enabled
May  8 10:27:25 HostOne ntpd[14529]: Listening on interface #30 eth1:1, 172.16.243.3#123 Enabled
May  8 10:27:25 HostOne ntpd[14529]: Listening on routing socket on fd #47 for interface updates
May  8 10:27:25 HostOne ntpd[14529]: kernel time sync status 2040
May  8 10:27:25 HostOne ntpd[14529]: frequency initialized -70.573 PPM from /var/lib/ntp/drift


Additional info:
The actual bug was observed on CentOS 6.2 - your customers are also affected!
Comment 2 RHEL Product and Program Management 2012-09-07 01:32:04 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 7 errata-xmlrpc 2013-11-21 04:51:33 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1593.html

Note You need to log in before you can comment on or make changes to this bug.