Bug 819804 - Package needs updating due to rpm automatic maven provides generation changes
Package needs updating due to rpm automatic maven provides generation changes
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: springframework (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Juan Hernández
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-08 05:14 EDT by Mattias Ellert
Modified: 2012-09-25 02:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-26 03:36:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mattias Ellert 2012-05-08 05:14:54 EDT
Description of problem:

The way the mvn(,,,) autogenerated provides in rpm are created has changed between jpackage-utils-1.7.5-16 and jpackage-utils-1.7.5-18.

springframework-3.1.1-2 was built using jpackage-utils-1.7.5-16 and the mvn(...) dependencies were added to the correct subpackages:

$ rpm -q --provides springframework | grep ^mvn
mvn(org.springframework:spring-core)
mvn(org.springframework:spring-parent)
$ rpm -q --provides springframework-aop | grep ^mvn
mvn(org.springframework:spring-aop)
$ rpm -q --provides springframework-beans | grep ^mvn
mvn(org.springframework:spring-beans)

However, springframework-3.1.1-3 was built using jpackage-utils-1.7.5-18 and all the mvn(...) provides are in the main package:

$ rpm -q --provides springframework | grep ^mvn
mvn(org.springframework:spring-aop)  
mvn(org.springframework:spring-beans)  
mvn(org.springframework:spring-context)  
mvn(org.springframework:spring-core)  
mvn(org.springframework:spring-expression)  
mvn(org.springframework:spring-instrument)  
mvn(org.springframework:spring-jdbc)  
mvn(org.springframework:spring-parent)  
mvn(org.springframework:spring-tx)

The reason is that these are now based on the maven fragments files rather than the pom files. In order for the mvn(...) provides in the springframework package to end up in the right subpackage the package must use a fragment file per subpackage (i.e. use the -f flag to the %add_maven_depmap macro) and put these in each subpackage respectively.

Version-Release number of selected component (if applicable):
springframework-3.1.1-3
Comment 1 Fedora Update System 2012-05-08 17:23:00 EDT
springframework-3.1.1-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/springframework-3.1.1-5.fc17
Comment 2 Juan Hernández 2012-05-08 17:26:17 EDT
Mattias, I think that release 5 should fix this issue. I would appreciate if you can download and test it.

Thanks for reporting the issue!
Comment 3 Mattias Ellert 2012-05-09 03:20:36 EDT
Yes, release 5 fixes this issue. I have a minor comments though:

The package should not own the /usr/share/maven-fragments directory since this directory is already owned by the jpackage-utils package. Instead it should declare a dependency on the jpackage-utils package. This is needed anyway, since the jpackage-utils package is the owner of e.g. /usr/share/java and /usr/share/maven-poms where the package is already installing files.
Comment 4 Juan Hernández 2012-05-09 03:28:44 EDT
You are right Mattias, the package should not own the /usr/share/maven-fragments, that is a mistake. I will fix it in release 6. I am also adding the dependency on jpackage-utils to the main package.
Comment 5 Fedora Update System 2012-05-09 04:02:44 EDT
springframework-3.1.1-6.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/springframework-3.1.1-6.fc17
Comment 6 Fedora Update System 2012-05-09 12:08:40 EDT
Package springframework-3.1.1-5.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing springframework-3.1.1-5.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7490/springframework-3.1.1-5.fc17
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-05-26 03:36:34 EDT
springframework-3.1.1-6.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2012-09-25 02:48:44 EDT
springframework-3.1.1-10.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/springframework-3.1.1-10.fc17

Note You need to log in before you can comment on or make changes to this bug.