Bug 819808 - [ALL_LANG] [RHSM FirstBoot] Unlocalized string 'No service levels ...' in Manual Configuration Required page when system registration without selecting 'Skip automatic subscription selection for this system'.
[ALL_LANG] [RHSM FirstBoot] Unlocalized string 'No service levels ...' in Man...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.3
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Adrian Likins
Entitlement Bugs
: Translation
Depends On:
Blocks: 738066
  Show dependency treegraph
 
Reported: 2012-05-08 05:17 EDT by Lijun Li
Modified: 2012-06-20 08:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 08:57:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Unlocalized string 'No service levels ...' in Manual Configuration Required page when system registration without selecting 'Skip automatic subscription selection for this system' (127.01 KB, image/png)
2012-05-08 05:19 EDT, Lijun Li
no flags Details

  None (edit)
Description Lijun Li 2012-05-08 05:17:16 EDT
Description of problem:
Unlocalized string 'No service levels ...' in Manual Configuration Required page when system registration without selecting 'Skip automatic subscription selection for this system'.

Version-Release number of selected component (if applicable):
subscription-manager-0.99.16-1.el6.x86_64


How reproducible:
100%

Steps to Reproduce:
1. Install latest RHEL6.3 build (Snapshot-2).
2. Go to first boot page or run # firstboot --reconfig on a terminal.
3. Register System using RHN account and password, but Do not select 'Skip automatic subscription selection for this system' option and click Forward.
  
Actual results:
Unlocalized string 'No service levels ...' in Manual Configuration Required page when system registration without selecting 'Skip automatic subscription selection for this system'.

Expected results:
It should be localized.

Additional info:
Comment 1 Lijun Li 2012-05-08 05:19:56 EDT
Created attachment 582932 [details]
Unlocalized string 'No service levels ...' in Manual Configuration Required page when system registration without selecting 'Skip automatic subscription selection for this system'
Comment 3 Ankit Patel 2012-05-10 02:03:39 EDT
Well this message is already translated in all Red Hat supported languages:

You might want to test it against subscription-manager-0.99.17-1 as well.

See below:
as.po:"No service levels will cover all installed products. Please use the \"All "
as.po-"Available Subscriptions\" tab to manually entitle this system."
as.po-msgstr ""
as.po-"কোনো সেৱা স্তৰে সকলো ইনস্টল উৎপাদন সুৰক্ষিত নকৰে। এই চিস্টেমক হস্তচালিতভাৱে অনুজ্ঞা "
--
bn.po:"No service levels will cover all installed products. Please use the \"All "
bn.po-"Available Subscriptions\" tab to manually entitle this system."
bn.po-msgstr ""
bn.po-"কোনো পরিসেবার স্তরের অধীন ইনস্টল করা উৎপাদনগুলির পরিচালনা করা সম্ভব নয়। অনুগ্রহ "
--
de.po:"No service levels will cover all installed products. Please use the \"All "
de.po-"Available Subscriptions\" tab to manually entitle this system."
de.po-msgstr ""
de.po-"Kein Service-Level deckt alle installierten Produkte ab. Bitte verwenden Sie "
--
es.po:"No service levels will cover all installed products. Please use the \"All "
es.po-"Available Subscriptions\" tab to manually entitle this system."
es.po-msgstr ""
es.po-"Ningún nivel de servicio cubrirá todos los productos instalados. Por favor "
--
fr.po:"No service levels will cover all installed products. Please use the \"All "
fr.po-"Available Subscriptions\" tab to manually entitle this system."
fr.po-msgstr ""
fr.po-"Aucun niveau de service ne couvrira tous les produits installés. Veuillez "
--
gu.po:"No service levels will cover all installed products. Please use the \"All "
gu.po-"Available Subscriptions\" tab to manually entitle this system."
gu.po-msgstr ""
gu.po-"સેવા સ્તરો બધી સ્થાપિત થયેલ પ્રોડક્ટોને આવરશે. મહેરબાની કરીને આ સિસ્ટમને અધિકાર આપવા માટે "
--
hi.po:"No service levels will cover all installed products. Please use the \"All "
hi.po-"Available Subscriptions\" tab to manually entitle this system."
hi.po-msgstr ""
hi.po-"कोई सेवा स्तर सभी संस्थापित उत्पादों को कवर नहीं करेगा. कृपया \"सभी उपलब्ध सदस्यताओं\" "
--
it.po:"No service levels will cover all installed products. Please use the \"All "
it.po-"Available Subscriptions\" tab to manually entitle this system."
it.po-msgstr ""
it.po-"Nessun livello di servizio ricoprirà tutti i prodotti installati. Usare la "
--
ja.po:"No service levels will cover all installed products. Please use the \"All "
ja.po-"Available Subscriptions\" tab to manually entitle this system."
ja.po-msgstr ""
ja.po-"インストールしている製品すべてを対象とするサービスレベルはありません。 「全て"
--
keys.pot:"No service levels will cover all installed products. Please use the \"All "
keys.pot-"Available Subscriptions\" tab to manually entitle this system."
keys.pot-msgstr ""
keys.pot-
--
kn.po:"No service levels will cover all installed products. Please use the \"All "
kn.po-"Available Subscriptions\" tab to manually entitle this system."
kn.po-msgstr ""
kn.po-"ಯಾವು ಸೇವಾ ಮಟ್ಟವೂ ಸಹ ಅನುಸ್ಥಾಪಿಸಲಾದ ಎಲ್ಲಾ ಉತ್ಪನ್ನಗಳನ್ನು ನೋಡಿಕೊಳ್ಳುವುದಿಲ್ಲ. ಈ "
--
ko.po:"No service levels will cover all installed products. Please use the \"All "
ko.po-"Available Subscriptions\" tab to manually entitle this system."
ko.po-msgstr ""
ko.po-"설치된 모든 제품에 적용되는 서비스 레벨이 없습니다. \"사용 가능한 모든 서브스"
--
ml.po:"No service levels will cover all installed products. Please use the \"All "
ml.po-"Available Subscriptions\" tab to manually entitle this system."
ml.po-msgstr ""
ml.po-"ഇന്‍സ്റ്റോള്‍ ചെയ്ത എല്ലാ പ്രൊഡക്ടുകള്‍ക്കുമുള്ള സര്‍വീസ് ലവലുകള്‍ ലഭ്യമല്ല. ഈ സിസ്റ്റം നിങ്ങള്‍ സ്വയം "
--
mr.po:"No service levels will cover all installed products. Please use the \"All "
mr.po-"Available Subscriptions\" tab to manually entitle this system."
mr.po-msgstr ""
mr.po-"कोणतेहि सर्व्हिस स्तर सर्व प्रतिष्ठापीत उत्पादने समाविष्ट करत नाही. कृपया \"सर्व उपलब्ध "
--
or.po:"No service levels will cover all installed products. Please use the \"All "
or.po-"Available Subscriptions\" tab to manually entitle this system."
or.po-msgstr ""
or.po-"କୌଣସି ସର୍ଭିସ ସ୍ତର ସମସ୍ତ ସ୍ଥାପିତ ଉତ୍ପାଦନଗୁଡ଼ିକୁ ଗ୍ରହଣ କରିନଥାଏ। \"ସମସ୍ତ ଉପଲବ୍ଧ ସଦସ୍ୟତା\" "
--
pa.po:"No service levels will cover all installed products. Please use the \"All "
pa.po-"Available Subscriptions\" tab to manually entitle this system."
pa.po-msgstr ""
pa.po-"ਕੋਈ ਵੀ ਸਰਵਿਸ ਲੈਵਲ ਸਭ ਇੰਸਟਾਲ ਕੀਤੇ ਉਤਪਾਦ ਕਵਰ ਨਹੀਂ ਕਰਦਾ। ਕਿਰਪਾ ਕਰਕੇਇਸ ਸਿਸਟਮ ਤੇ ਦਸਤੀ "
--
pt_BR.po:"No service levels will cover all installed products. Please use the \"All "
pt_BR.po-"Available Subscriptions\" tab to manually entitle this system."
pt_BR.po-msgstr ""
pt_BR.po-
--
pt.po:"No service levels will cover all installed products. Please use the \"All "
pt.po-"Available Subscriptions\" tab to manually entitle this system."
pt.po-msgstr ""
pt.po-"Nenhum nível de serviço irá cobrir todos os produtos instalados. Por favor, "
--
ru.po:"No service levels will cover all installed products. Please use the \"All "
ru.po-"Available Subscriptions\" tab to manually entitle this system."
ru.po-msgstr ""
ru.po-"Уровни обслуживания не охватывают все установленные продукты. Чтобы "
--
ta.po:"No service levels will cover all installed products. Please use the \"All "
ta.po-"Available Subscriptions\" tab to manually entitle this system."
ta.po-msgstr ""
ta.po-" உரிமங்களால் அனைத்து நிறுவப்பட்ட தயாரிப்புகளும் கொண்டுள்ளது. இந்த நேரத்தில் சான்றிதழை "
--
te.po:"No service levels will cover all installed products. Please use the \"All "
te.po-"Available Subscriptions\" tab to manually entitle this system."
te.po-msgstr ""
te.po-"అన్ని సంస్థాపిత వుత్పత్తులను యే సేవా స్థాయిలు కవర్ చేయవు. ఈ సిస్టమ్‌ను మానవీయంగా యెన్టైటిల్ చేయుటకు "
--
zh_CN.po:"No service levels will cover all installed products. Please use the \"All "
zh_CN.po-"Available Subscriptions\" tab to manually entitle this system."
zh_CN.po-msgstr ""
zh_CN.po-"没有任何服务等级可覆盖所有安装的产品。请使用“所有可用订阅”标签手动为这个系统"
--
zh_TW.po:"No service levels will cover all installed products. Please use the \"All "
zh_TW.po-"Available Subscriptions\" tab to manually entitle this system."
zh_TW.po-msgstr ""
zh_TW.po-"沒有服務等即可涵蓋所有已安裝產品。請使用「所有可用訂閱」分頁來手動賦予系統權"
Comment 4 Adrian Likins 2012-05-10 10:56:22 EDT
Looks like the original message:

    No service levels will cover all installed products. Please run 'Subscription 
    Manager' to manually entitle this system.

was split in the src in a way inttool didn't pick up the entire string, so
only:

     No service levels will cover all installed products.

got marked for translations and translated. Though, not even that subsstring
shows up as translated, since the string in the code is the longer one and
gettext doesn't match it to the shorted msgid. 

We can split the string in the code to something like:


message = _("No service levels will cover all installed products. ") + \
          _("Please run 'Subscription Manager' to manually entitle this system.")

The first part is marked and translated, the second part is not. So not 100%.

option 1)
Just remove the latter part of the string
option 2)
Fix the first part to show translations and let second part be untranslated


However, checking for existing strings I see:

      "Unable to auto-subscribe, server does not support service levels. Please 
       run Subscription Manager' to manually subscribe."

and:


"Unable to subscribe to any additional products at current service level: %s. "
"Please use the \"All Available Subscriptions\" tab to manually entitle this "
"system."

"No service levels will cover all installed products. Please use the \"All "
"Available Subscriptions\" tab to manually entitle this system."


"You will need to manually subscribe this system after completing firstboot. "
"Subscription Manager can be found in <b>System > Administration > "
"Subscription Manager</b>."


We could substitute one of these for the original message. None are perfect though.
Comment 5 Adrian Likins 2012-05-10 14:36:52 EDT
commit 3cffd94ec8fcb7d3352176478d99afca328ba082
Author: Adrian Likins <alikins@redhat.com>
Date:   Thu May 10 14:05:31 2012 -0400

    819808: Fix untranslated string "No service levels..."
    
    This string wasn't extracted into the msg catalog correctly,
    so only the first line is tranlated, so update the message
    itself so we find the translations for it.
Comment 9 Lijun Li 2012-05-18 03:28:12 EDT
Verified, it's fixed on subscription-manager-firstboot-0.99.18-1.el6.x86_64.
Comment 12 errata-xmlrpc 2012-06-20 08:57:15 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0804.html

Note You need to log in before you can comment on or make changes to this bug.