Bug 819833 - wrong exit code when destroying domain with non-exist name
wrong exit code when destroying domain with non-exist name
Status: CLOSED DUPLICATE of bug 811221
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Krishna Raman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-08 06:24 EDT by Meng Bo
Modified: 2015-05-14 21:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-08 07:48:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Meng Bo 2012-05-08 06:24:27 EDT
Description of problem:
destroy domain with non-exist name will get exit code 0,

Version-Release number of selected component (if applicable):
devenv_1761

How reproducible:
always

Steps to Reproduce:
1.create domain 
rhc domain create -n testdomain
2.destroy domain with non-existed name
rhc domain destroy -n testdomainnew
  
Actual results:
exit code 0 returned, and domain did not be destroyed.

Expected results:
other exit code returned.

Additional info:
[root@localhost openshift]# rhc domain destroy -n ttt -d
Password: 
Submitting form:
namespace: ttt
delete: true
rhlogin: bmeng+auto2@redhat.com
Contacting https://ec2-23-21-35-107.compute-1.amazonaws.com
Problem reported from server. Response code was 400.

DEBUG:


Exit Code: 0
broker_c: namespacerhloginsshapp_uuiddebugaltercartridgecart_typeactionapp_nameapi
api_c: placeholder
API version:    1.1.3

RESULT:
Cannot alter or remove namespace ttt. Namespace does not exist.
Comment 1 Xiaoli Tian 2012-05-08 07:48:52 EDT

*** This bug has been marked as a duplicate of bug 811221 ***

Note You need to log in before you can comment on or make changes to this bug.