Bug 819835 - Installation failed when device names contain spaces
Installation failed when device names contain spaces
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
: Regression
Depends On:
Blocks: 736493
  Show dependency treegraph
 
Reported: 2012-05-08 06:27 EDT by shine
Modified: 2016-04-26 11:19 EDT (History)
13 users (show)

See Also:
Fixed In Version: ovirt-node-2.3.0-6.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-19 10:12:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
WrongDeviceName (414.97 KB, application/zip)
2012-05-08 06:27 EDT, shine
no flags Details

  None (edit)
Description shine 2012-05-08 06:27:06 EDT
Created attachment 582952 [details]
WrongDeviceName

Description of problem:

  Installation failed on IBM System x3755 for the RHEVH gets the wrong device name.
  The older RHEV-H 6.3-20120419.0.el6 gets the device name:SServeRA_QEServer_F8BC3124[atachment Localstorage.png], and is installed successfully.
  The RHEV-H 6.3-20120426 and RHEV-H-20120502 gets the incomplete device name:SServeRA[atachment Localstorage2.png], and gets failure installation.
  The incomplete device name results in the error after sfdisk in code.   size_cmd = "sfdisk -s " + drive + " 2>null"


Version-Release number of selected component (if applicable):
  rhev-hypervisor6-6.3-20120426.2.el6
  rhev-hypervisor6-6.3-20120502.3.el6

How reproducible:
  100%

  Steps to Reproduce:
  1. Clean install RHEV-H 6.3-20120426.0.el6 on IBM System x3755.
  2. Boot from PXE choose the RHEV-H 6.3-20120426.2.el6.

Actual results:
  1. RHEVH couldn't be installed successfully, and an exception occured. See pic:[ibminstall0426Exception.png]
  2. But the RHEV-H 6.3-20120419.0.el6 could be installed successfully

  Expected results:
  The RHEV-H 6.3-20120426.2.el6 and rhev-hypervisor6-6.3-20120502.3.el6 could be installed successfully.

Additional info:
Comment 3 Mike Burns 2012-05-08 08:11:40 EDT
Can you drop to a shell and look at what is under /dev/mapper?

Do device names contain spaces?  

This looks like it's caused by the fix for bug 736493.  I'll revert that fix.
Comment 4 Fabian Deutsch 2012-05-08 11:36:35 EDT
I was able to reproduce this in a VM giving a harddisk the same serial (SServeRA_QEServer_F8BC3124).
Comment 5 shine 2012-05-08 21:50:08 EDT
(In reply to comment #3)
> Can you drop to a shell and look at what is under /dev/mapper?
> 
> Do device names contain spaces?  
> 
> This looks like it's caused by the fix for bug 736493.  I'll revert that fix.

Here is the result. One of the device names contains spaces.The following is the detailed info:
[root@dhcp-66-83-238 ~]# ll /dev/mapper
total 0
crw-rw----. 1 root root  10, 58 2012-05-08 09:12 control
lrwxrwxrwx. 1 root root       7 2012-05-08 09:12 HostVG-Config -> ../dm-7
lrwxrwxrwx. 1 root root       7 2012-05-08 09:12 HostVG-Data -> ../dm-9
lrwxrwxrwx. 1 root root       7 2012-05-08 09:12 HostVG-Logging -> ../dm-8
lrwxrwxrwx. 1 root root       7 2012-05-08 09:12 HostVG-Swap -> ../dm-6
lrwxrwxrwx. 1 root root       7 2012-05-08 09:12 live-rw -> ../dm-5
brw-rw----. 1 root disk 253,  0 2012-05-08 09:12 SServeRA QEServer       F8BC3124
lrwxrwxrwx. 1 root root       7 2012-05-08 09:31 SServeRA_QEServer_F8BC3124 -> ../dm-1
lrwxrwxrwx. 1 root root       7 2012-05-08 09:31 SServeRA_QEServer_F8BC3124p1 -> ../dm-3
lrwxrwxrwx. 1 root root       8 2012-05-08 09:31 SServeRA_QEServer_F8BC3124p2 -> ../dm-10
lrwxrwxrwx. 1 root root       8 2012-05-08 09:31 SServeRA_QEServer_F8BC3124p3 -> ../dm-11
lrwxrwxrwx. 1 root root       8 2012-05-08 09:31 SServeRA_QEServer_F8BC3124p4 -> ../dm-12
lrwxrwxrwx. 1 root root       7 2012-05-08 09:13 SServeRA\x20QEServer\x20\x20\x20\x20\x20\x20\x20F8BC3124 -> ../dm-0
lrwxrwxrwx. 1 root root       7 2012-05-08 09:13 SServeRA\x20QEServer\x20\x20\x20\x20\x20\x20\x20F8BC3124p2 -> ../dm-2
lrwxrwxrwx. 1 root root       7 2012-05-08 09:13 SServeRA\x20QEServer\x20\x20\x20\x20\x20\x20\x20F8BC3124p4 -> ../dm-4
[root@dhcp-66-83-238 ~]# ll /dev/mapper/SServeRA_QEServer_F8BC3124
lrwxrwxrwx. 1 root root 7 2012-05-08 09:31 /dev/mapper/SServeRA_QEServer_F8BC3124 -> ../dm-1
[root@dhcp-66-83-238 ~]# ll /dev/mapper/SServeRA\ QEServer\ \ \ \ \ \ \ F8BC3124 
brw-rw----. 1 root disk 253, 0 2012-05-08 09:12 /dev/mapper/SServeRA QEServer       F8BC3124
Comment 11 yuanquan chen 2012-05-15 02:12:11 EDT
Verified with rhevh-6.3-20120509.1. The device mapper name doesn't contain space anymore and the install to it successes.
Comment 13 errata-xmlrpc 2012-07-19 10:12:53 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0741.html

Note You need to log in before you can comment on or make changes to this bug.