Bug 819850 - ATI radeon graphic card not recognised in f17
ATI radeon graphic card not recognised in f17
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-08 07:45 EDT by Rodd Clarkson
Modified: 2012-05-09 09:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-09 00:38:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log file (114.55 KB, text/x-log)
2012-05-08 07:45 EDT, Rodd Clarkson
no flags Details
Smolt Profile (3.70 KB, text/plain)
2012-05-08 07:50 EDT, Rodd Clarkson
no flags Details
Xorg.0.log file with no xorg.conf (121.45 KB, text/x-log)
2012-05-08 08:03 EDT, Rodd Clarkson
no flags Details
dmesg output from f17 (69.62 KB, text/plain)
2012-05-08 08:06 EDT, Rodd Clarkson
no flags Details

  None (edit)
Description Rodd Clarkson 2012-05-08 07:45:52 EDT
Created attachment 582967 [details]
Xorg.0.log file

Description of problem:

I have a laptop with a radeon display that's been working fine using
f16, but now the best I get is VESA.

I've tried updating but it still boots with the blue/white bars at the
bottom, instead of the graphic boot and the best resolution I can get
is 1400x900 (the display is 1920x1080).

I'm not sure if I need to pass something at start-up, but this seems
like a significant regression as the display worked well with f16.

Adam suggested I include a little extra information on fedora-devel, so I'll attached it as I gather it.
Comment 1 Rodd Clarkson 2012-05-08 07:50:23 EDT
Created attachment 582969 [details]
Smolt Profile

Had a quick look through this and the graphics card isn't listed which seems strange.  

I'll have a look at my smolt profile in f16 and see what it reports.
Comment 2 Rodd Clarkson 2012-05-08 07:54:48 EDT
It did have an xorg.conf file in /etc/X11 which contained the following:

Section "Device"
        Identifier "Videocard0"
        Driver "vesa"
EndSection


I've moved this file to xorg.conf.bup and logged out and back in and there's no change.  I'm still using the VESA driver
Comment 3 Rodd Clarkson 2012-05-08 08:03:44 EDT
Created attachment 582970 [details]
Xorg.0.log file with no xorg.conf

This has got information about ATI in it, but it still defaults to using the VESA driver.
Comment 4 Rodd Clarkson 2012-05-08 08:04:44 EDT
Removing the xorg.conf file has actually improved things (but it's still not working).  This time the Xorg.0.log file shows information about the ATI drivers, but it's still using VESA.
Comment 5 Rodd Clarkson 2012-05-08 08:06:53 EDT
Created attachment 582971 [details]
dmesg output from f17
Comment 6 Kevin Fenzi 2012-05-08 08:57:10 EDT
Remove the 'nomodeset' from your /etc/grub2.cfg (or manually on boot).
Comment 7 Adam Jackson 2012-05-08 10:10:58 EDT
(In reply to comment #6)
> Remove the 'nomodeset' from your /etc/grub2.cfg (or manually on boot).

What he said.
Comment 8 Adam Williamson 2012-05-08 10:36:58 EDT
Right. It sounds like, somehow, you ran the installation with 'basic graphics driver' option.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 9 Rodd Clarkson 2012-05-08 21:55:38 EDT
You guys are amazing.  I've removed 'nomodeset' from /etc/grub2.cfg and this has resolved the issue.

The comment about 'basic graphics driver' option is right, but I'm not sure how I got there.  I'll go and boot of the installer disk and see why I ended up selecting that option and if I missed something.

Thanks
Comment 10 Adam Williamson 2012-05-09 00:38:01 EDT
I'm gonna close this as NOTABUG, then, as everything behaved as intended. If it turns out there was some other problem which prompted you to choose 'basic graphics mode' on install, please file a separate bug for that, so we don't get confused by 8 comments of preamble :)



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 11 Rodd Clarkson 2012-05-09 02:57:01 EDT
Leave it closed.  Turns out I must have pressed a wrong key and missed the first screen ending up in the second option for recovery.

Might be worth adding a standard install option in that menu, but mostly I should just concentrate.

Thanks for your support.
Comment 12 Adam Williamson 2012-05-09 09:55:46 EDT
You can hit 'esc' to get back to the top level, FWIW.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.