Bug 819902 - KeyError: 'en-gb'
KeyError: 'en-gb'
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.0
All Linux
high Severity high
: alpha
: 7.0
Assigned To: Anaconda Maintenance Team
Release Test Team
abrt_hash:5760839151e3a2e7ba827936802...
:
Depends On: 789725
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-08 10:56 EDT by Vladimir Benes
Modified: 2014-09-13 14:58 EDT (History)
9 users (show)

See Also:
Fixed In Version: anaconda-17.26-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 789725
Environment:
Last Closed: 2014-06-13 08:19:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vladimir Benes 2012-05-08 10:56:10 EDT
+++ This bug was initially created as a clone of Bug #789725 +++

libreport version: 2.0.6
executable:     /usr/bin/python
hashmarkername: anaconda
kernel:         3.1.0-7.fc16.i686
product:        Fedora
reason:         KeyError: 'en-gb'
time:           Sun Feb 12 17:26:39 2012
version:        16

anaconda-tb-gkU7UN: Text file, 240927 bytes

description:
:The following was filed automatically by anaconda:
:anaconda 16.25 exception report
:Traceback (most recent call first):
:  File "/usr/lib/python2.7/site-packages/system_config_keyboard/keyboard.py", line 81, in set
:    kb = self.modelDict[keytable]
:  File "/usr/lib/python2.7/site-packages/pyanaconda/kickstart.py", line 429, in execute
:    self.anaconda.keyboard.set(self.keyboard)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/kickstart.py", line 1226, in execute
:    obj.execute()
:  File "/usr/lib/python2.7/site-packages/pyanaconda/kickstart.py", line 1277, in doKickstart
:    anaconda.ksdata.execute()
:  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 373, in dispatch
:    self.dir = self.steps[self.step].target(self.anaconda)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 88, in return_false
:    func(*args, **kwargs)
:KeyError: 'en-gb'

--- Additional comment from neil@fnxweb.com on 2012-02-12 12:27:44 EST ---

Created attachment 561241 [details]
File: anaconda-tb-gkU7UN

--- Additional comment from neil@fnxweb.com on 2012-02-12 13:08:37 EST ---

In debug, keytrable is always set to 'en-gb' nomatter what menu option I select on the initial screen.  I've tried editing the grub command line to add KEYTABLE=uk (which seems to be a valid entry for this dict), but it didn't change anything.

I don't know how to make anaconda use the keyboard setting I've given it.

This is preupgrading F14 to F16.

--- Additional comment from neil@fnxweb.com on 2012-02-13 06:57:07 EST ---

It appears to have copied a legacy value of KEYTABLE from /etc/sysconfig/keyboard into /boot/upgrade/ks.cfg and that then isn't being checked for a valid value.  I have gotten around it by fixing the ks.cfg file.

Anaconda should probably check at least that value there before using them;  alternatively, preupgrade should have not written it if it were unacceptable ( I think the list of valid kickstart keyboard settings is fixed).

--- Additional comment from mholec@redhat.com on 2012-05-07 10:25:53 EDT ---

This bug blocks unattended installation in Gnome Boxes. I get same trackback.

--- Additional comment from bcl@redhat.com on 2012-05-07 10:37:30 EDT ---

Please attach your kickstart (with private info removed).

--- Additional comment from mholec@redhat.com on 2012-05-08 09:23:19 EDT ---

Created attachment 582992 [details]
Kickstart file by Gnome Boxes

I attached kickstart file created by Gnome Boxes.

--- Additional comment from zali@redhat.com on 2012-05-08 09:35:53 EDT ---

Comment on attachment 582992 [details]
Kickstart file by Gnome Boxes

> Created attachment 582992 [details]
> Kickstart file by Gnome Boxes
> 
> I attached kickstart file created by Gnome Boxes.

Thats *not* the kickstart file but the binary image of the floppy disk on which the kickstart file is put. You can grab the kickstart file using:

mcopy -i ~/.cache/gnome-boxes/fedora17-unattended.img ::ks.cfg .

--- Additional comment from mholec@redhat.com on 2012-05-08 09:39:09 EDT ---

Created attachment 582993 [details]
Kickstart file image by Gnome Boxes

I attached correct kickstart file image created by Gnome Boxes. strings decoded dump follows:

mkdosfs
           FAT12   
This is not a bootable disk.  Please insert a bootable floppy and
press any key to try again ... 
KS      CFG 
install
keyboard cz
lang cs_CZ.UTF-8
network --onboot yes --device eth0 --bootproto dhcp --noipv6 --activate
rootpw redhat
firewall --disabled
authconfig --enableshadow --enablemd5
selinux --enforcing
timezone --utc CEST
bootloader --location=mbr
zerombr
clearpart --all --drives=sda
firstboot --disable
part biosboot --fstype=biosboot --size=1
part /boot --fstype ext4 --recommended --ondisk=sda
part pv.2 --size=1 --grow --ondisk=sda
volgroup VolGroup00 --pesize=32768 pv.2
logvol swap --fstype swap --name=LogVol01 --vgname=VolGroup00 --size=768 --grow --maxsize=1536
logvol / --fstype ext4 --name=LogVol00 --vgname=VolGroup00 --size=1024 --grow
reboot
user --name=test --password=redhat
%packages
@base
@core
@hardware-support
@base-x
@gnome-desktop
@graphical-internet
@sound-and-video
# QXL video driver and SPICE vdagent
xorg-x11-drv-qxl
spice-vdagent
%end
%post --erroronfail
# Add user to admin group
usermod -a -G wheel test
# Enable autologin
echo "[daemon]
AutomaticLoginEnable=true
AutomaticLogin=test
[security]
[xdmcp]
[greeter]
[chooser]
[debug]
" > /etc/gdm/custom.conf
%end
Comment 4 Ludek Smid 2014-06-13 08:19:59 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.