Bug 819913 - koan should require python-ethtool
koan should require python-ethtool
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: cobbler (Show other bugs)
17
All Linux
unspecified Severity low
: ---
: ---
Assigned To: James C.
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-08 11:34 EDT by Orion Poplawski
Modified: 2012-05-22 12:02 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-21 22:05:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2012-05-08 11:34:28 EDT
Description of problem:

# koan --replace-self
- looking for Cobbler at http://cobbler.cora.nwra.com:80/cobbler_api
the rhpl or ethtool module is required to use this feature (is your OS>=EL3?)

Version-Release number of selected component (if applicable):
koan-2.2.2-1.fc17.noarch
Comment 1 James C. 2012-05-21 22:05:56 EDT
This is not required because it's an either/or situation:

def get_network_info():
   try:
      import ethtool
   except:
      try:
         import rhpl.ethtool
         ethtool = rhpl.ethtool
      except:
           raise InfoException("the rhpl or ethtool module is required to use this feature (is your OS>=EL3?)")


Adding a requirement on one would exclude the other, so neither are required and the import error is handled gracefully with a suggestion to install the one available for your distro.
Comment 2 James C. 2012-05-21 22:08:23 EDT
This is not required because it's an either/or situation:

def get_network_info():
   try:
      import ethtool
   except:
      try:
         import rhpl.ethtool
         ethtool = rhpl.ethtool
      except:
           raise InfoException("the rhpl or ethtool module is required to use this feature (is your OS>=EL3?)")


Adding a requirement on one would exclude the other, so neither are required and the import error is handled gracefully with a suggestion to install the one available for your distro.
Comment 3 Orion Poplawski 2012-05-22 12:02:08 EDT
I disagree.  I filed this bug against *Fedora*, not cobbler in general.  In Fedora, there is no rhpl.ethtool, only python-ethtool, and it should be required by the Fedora koan package.

Note You need to log in before you can comment on or make changes to this bug.