Bug 819914 - Python package versions out of sync for 32 and 64bit packages.
Python package versions out of sync for 32 and 64bit packages.
Status: CLOSED DUPLICATE of bug 733464
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: releng (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Dennis Gregorovic
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-08 11:36 EDT by Kai Meyer
Modified: 2012-05-08 14:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-08 14:47:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kai Meyer 2012-05-08 11:36:48 EDT
Description of problem:
Available rpms for python and python-devel on RHEL 6.2 are out of sync between x86_64 and i686. Therefore installing python-devel.i686 fails. If you select the older version of x86_64 packages (ie: with yumdowngrade) you can get them installed.


Version-Release number of selected component (if applicable):



How reproducible:
Just have yum list python and python-devel packages.

Steps to Reproduce:
1. yum list python python-devel
2.
3.
  
Actual results:
Loaded plugins: auto-update-debuginfo, refresh-packagekit, rhnplugin
Installed Packages
python.x86_64       2.6.6-29.el6      @rhel-x86_64-workstation-6
python-devel.x86_64 2.6.6-29.el6      @rhel-x86_64-workstation-6
Available Packages
python.i686         2.6.5-3.el6_0.2   rhel-x86_64-workstation-6 
python-devel.i686   2.6.5-3.el6_0.2   rhel-x86_64-workstation-6 


Expected results:
Versions to be the same.


Additional info:
Comment 2 Kai Meyer 2012-05-08 12:04:33 EDT
I was going to open a new bug against boost for having similar behavior, but this looks like the right place to bring it up.

I'm actually more interested in making boost work correctly, but boost-python shows this behavior as well.

If you install boost\*-1.41.0-11.el6 boost\*-1.41.0-11.el6.i686, and then do a yum list boost\*, you'll see the following list of i686 pcakges that do not have a 1.41.0-11.el6_1.2 version.

$ sudo yum list boost boost.i686 boost-devel boost-devel.i686 boost-graph-mpich2 boost-graph-mpich2.i686 boost-mpich2 boost-mpich2.i686 boost-mpich2-devel boost-mpich2-devel.i686 boost-mpich2-python boost-mpich2-python.i686 boost-openmpi-devel boost-openmpi-devel.i686 boost-python boost-python.i686 
Loaded plugins: auto-update-debuginfo, refresh-packagekit, rhnplugin
Installed Packages
boost.x86_64                                 1.41.0-11.el6                        @rhel-x86_64-workstation-6         
boost-devel.i686                             1.41.0-11.el6                        @rhel-x86_64-workstation-6         
boost-devel.x86_64                           1.41.0-11.el6                        @rhel-x86_64-workstation-6         
boost-graph-mpich2.i686                      1.41.0-11.el6                        @rhel-x86_64-workstation-optional-6
boost-graph-mpich2.x86_64                    1.41.0-11.el6                        @rhel-x86_64-workstation-optional-6
boost-mpich2.i686                            1.41.0-11.el6                        @rhel-x86_64-workstation-optional-6
boost-mpich2.x86_64                          1.41.0-11.el6                        @rhel-x86_64-workstation-optional-6
boost-mpich2-devel.i686                      1.41.0-11.el6                        @rhel-x86_64-workstation-optional-6
boost-mpich2-devel.x86_64                    1.41.0-11.el6                        @rhel-x86_64-workstation-optional-6
boost-mpich2-python.i686                     1.41.0-11.el6                        @rhel-x86_64-workstation-optional-6
boost-mpich2-python.x86_64                   1.41.0-11.el6                        @rhel-x86_64-workstation-optional-6
boost-openmpi-devel.i686                     1.41.0-11.el6                        @rhel-x86_64-workstation-optional-6
boost-openmpi-devel.x86_64                   1.41.0-11.el6                        @rhel-x86_64-workstation-optional-6
boost-python.i686                            1.41.0-11.el6                        @rhel-x86_64-workstation-6         
boost-python.x86_64                          1.41.0-11.el6                        @rhel-x86_64-workstation-6         
Available Packages
boost.x86_64                                 1.41.0-11.el6_1.2                    rhel-x86_64-workstation-6          
boost-devel.x86_64                           1.41.0-11.el6_1.2                    rhel-x86_64-workstation-6          
boost-graph-mpich2.x86_64                    1.41.0-11.el6_1.2                    rhel-x86_64-workstation-optional-6 
boost-mpich2.x86_64                          1.41.0-11.el6_1.2                    rhel-x86_64-workstation-optional-6 
boost-mpich2-devel.x86_64                    1.41.0-11.el6_1.2                    rhel-x86_64-workstation-optional-6 
boost-mpich2-python.x86_64                   1.41.0-11.el6_1.2                    rhel-x86_64-workstation-optional-6 
boost-openmpi-devel.x86_64                   1.41.0-11.el6_1.2                    rhel-x86_64-workstation-optional-6 
boost-python.x86_64                          1.41.0-11.el6_1.2                    rhel-x86_64-workstation-6
Comment 3 Dennis Gregorovic 2012-05-08 14:47:28 EDT

*** This bug has been marked as a duplicate of bug 733464 ***

Note You need to log in before you can comment on or make changes to this bug.