Bug 81994 - Graphical install hangs on HP Pavilion laptop
Graphical install hangs on HP Pavilion laptop
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
:
Depends On:
Blocks: 79578
  Show dependency treegraph
 
Reported: 2003-01-15 22:41 EST by Linus Torvalds
Modified: 2008-01-17 12:49 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-25 10:58:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Linus Torvalds 2003-01-15 22:41:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
While still in text-mode, the machine hangs when the installer
asks the "verify CDROM media (yes) (no)" question if the graphical
install has been selected.

No keyboard reaction, no nothing.  I assume that this is the
phase where the install is probing the graphics hardware for
the first time or similar.

When doing a text install, install continues normally. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot CD 1, select graphical install
2.Watch it hang
3.Profit!
    

Actual Results:  Total hang, no way out except rebooting the machine

Expected Results:  I would have expected to be able to select the "don't check
media" option and started the install.

Additional info:

HP Pavilion ze5155 P4 notebook computer, 512MB RAM,
ATI Mobility M6 graphics card.
Comment 1 Matt Wilson 2003-01-15 23:16:06 EST
That's odd.  We've gotten a few of these - could be a kudzu/keyboard init
interaction problem.  I don't know if we have this model handy.
Comment 2 Matt Wilson 2003-01-15 23:19:08 EST
Do you have a USB keyboard handy that you could try attaching to the laptop to
get through the install?  I'm curious to know if the keyboard works properly
post-install.
Comment 3 Matt Wilson 2003-01-15 23:26:28 EST
could be a dup of #81243
Comment 4 Matt Wilson 2003-01-15 23:30:33 EST
I probably didn't read your report correctly.  The first try locked up at the
media check option, but then cold starting the machine let you continue with a
text mode installation.  This could be a warmboot problem - did you boot into
the installer cold or warm?
Comment 5 Linus Torvalds 2003-01-15 23:46:53 EST
Happens both cold and warm, as far as I can tell. I think I tried both.

However, I'll double-check once the text-mode install has completely
finished, just to verify that it _does_ finish.

Btw, not being able to use email to update bug stuff sucks. 
Comment 6 Linus Torvalds 2003-01-15 23:48:20 EST
Btw, no USB keyboards around tonight, and I probably won't have time
to snarf one before leaving on vacation Friday. Will try.
Comment 7 Linus Torvalds 2003-01-16 00:03:56 EST
I was wrong, you were right - it does _not_ happen on a cold boot.
So the gaphics vs text mode installation is apparently a red herring,
and the real issue is cold boot vs warm boot.

It turns out graphics mode install doesn't work that well anyway, but
that's a separate problem: XFree86 has trouble synching on the TFT-screen
on this machine. Doing a console switch back to text mode and then back
to graphics mode sometimes fixes that. And sometimes not.
Comment 8 Matt Wilson 2003-01-16 00:16:13 EST
(on the email bit - we're doing testing for the bugzilla email gateway - so that
should be coming in the not-too-distant future)

Interesting that things aren't working on the warm boot.  Is it hanging at the
media check screen or just after you select "don't check"?

On the X problem - is this a 1024x768 15" display?
Comment 9 Linus Torvalds 2003-01-16 01:28:10 EST
The keyboard goes away _before_ I can do the "don't check" thing. Which
is the first thing that asks for keyboard input.

In fact, by pressing the caps-lock key and looking at the caps-lock
LED, I can tell that the keyboard is dead already when the kernel is
booting (but it worked in the BIOS), so it's definitely a RH kernel
problem, and has nothing to do with any later probing of hardware by
the install sequence.

Btw, both SuSE 8.1 and current 2.5.x work fine on this same machine,
so the keyboard problem is very much RH-specific. (The xfree86 problem
is something generic).

And yes, that is a 1024x768 15" display. 
Comment 10 Matt Wilson 2003-01-16 01:44:41 EST
We're going to revert some userland ps/2 probing code.  You're probably right
that it won't fix your case though.  Don't know what might be wrong in the
kernel, though.  Arjan?
Comment 11 Linus Torvalds 2003-01-16 01:56:45 EST
Doing more testing (at least 25 reboots) shows that it's not repeatable
after all. I had at least 10 consecutive successful soft reboots when I
was pressing caps-lock while the kernel was booting. And then several
failures, including at least one with the installed kernel (ie the one
loaded from harddisk, not the CD-ROM installation kernel). I'm pretty
sure one of them was from a cold boot too.

In short, no real patterns after all. Sometimes it works, sometimes it
doesn't. Sometimes it seems to stop working within the same boot (ie
caps-lock worked for a while, then stopped), and sometimes it seems to
not have worked at all during a boot (but maybe it worked for a window
I just didn't notice).
Comment 12 Arjan van de Ven 2003-01-16 05:06:12 EST
I don't have patches against keyboard stuff; the patches Alan had in his tree I
backed out because those were indeed broken.. so why it fails... does the loader
probe the ps/2 ports that early ?
Comment 13 Matt Wilson 2003-01-16 11:18:17 EST
loader doesn't probe ps/2 ports directly.  The mouse probe begins in stage 2 of
the installer (once you've mounted the media, etc).  It could be that our
modified ps/2 probe code places things in an odd state, and if you warm reboot
after the install things go wrong.
Comment 14 Matt Wilson 2003-01-16 12:56:52 EST
I'm going to point my finger at the kudzu ps/2 probe code, which did some very
dubious things (disable port, fail probe, didn't re-enable port).  The next beta
will not use the newer (broken) code.
Comment 15 Matt Wilson 2003-01-16 16:26:54 EST
Oh, another note - on the laptop and screen not working properly - it may work
better if you run at the native lcd resolution.  Boot into the installation
program with "linux resolution=1024x768"
Comment 16 Matt Wilson 2003-01-24 12:58:32 EST
Please try again with Pheobe beta2 (now on ftp.redhat.com)
Comment 17 Brent Fox 2003-05-25 10:58:34 EDT
I'm going through Bugzilla closing some bugs that have been marked as Modified
for some period of time.  I believe that most of these issues have been fixed,
so I'm resolving these bugs as Rawhide.  If the bug you are seeing still exists,
please reopen this report and mark it as Reopened.

Note You need to log in before you can comment on or make changes to this bug.