Bug 819943 - RFE: Limit raid-check cron to a maximum number of concurrent checks
RFE: Limit raid-check cron to a maximum number of concurrent checks
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: mdadm (Show other bugs)
6.2
Unspecified Unspecified
medium Severity unspecified
: rc
: ---
Assigned To: Jes Sorensen
XiaoNi
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-08 12:43 EDT by Orion Poplawski
Modified: 2013-11-21 07:03 EST (History)
4 users (show)

See Also:
Fixed In Version: mdadm-3.2.6-3.el6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 07:03:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to add MAXCONCURRENT (2.48 KB, patch)
2012-05-08 12:43 EDT, Orion Poplawski
no flags Details | Diff
Patch to add MAXCONCURRENT to raid-check (2.14 KB, patch)
2012-05-30 11:19 EDT, Orion Poplawski
no flags Details | Diff

  None (edit)
Description Orion Poplawski 2012-05-08 12:43:54 EDT
Created attachment 583043 [details]
Patch to add MAXCONCURRENT

Description of problem:

I've got some disk servers with 4 9TB radi5 arrays.  raid-check puts too much
of a load on them.  The attached patch (to mdadm-3.2.2-9) allows the use of a
MAXCONCURENT option that limits the number of concurrently checked arrays.

This is a quick port of the EL5 version.  Will test it out this weekend.

Version-Release number of selected component (if applicable):
mdadm-3.2.2-9
Comment 2 Jes Sorensen 2012-05-09 03:43:44 EDT
Orion,

This is definitely too late for 6.3, but lets consider it for 6.4.

In the mean time I recommend we push it into Fedora first and let it soak
there for a bit first.

I will clone this BZ into a Fedora one and push it there first, if that is
ok with you.

Cheers,
Jes
Comment 3 Jes Sorensen 2012-05-30 02:59:16 EDT
Orion,

How did you get along with the testing?

Thanks,
Jes
Comment 4 Orion Poplawski 2012-05-30 11:11:52 EDT
Doesn't work, it checks the same array each time:

May 27 01:00:01 alexandria2 kernel: md: data-check of RAID array md1
May 27 01:00:01 alexandria2 kernel: md: minimum _guaranteed_  speed: 1000 KB/sec/disk.
May 27 01:00:01 alexandria2 kernel: md: using maximum available idle IO bandwidth (but not more than 200000 KB/sec) for data-check.
May 27 01:00:01 alexandria2 kernel: md: using 128k window, over a total of 77943740k.
May 27 01:27:51 alexandria2 kernel: md: md1: data-check done.
May 27 01:28:08 alexandria2 kernel: md: data-check of RAID array md1
May 27 01:28:08 alexandria2 kernel: md: minimum _guaranteed_  speed: 1000 KB/sec/disk.          
May 27 01:28:08 alexandria2 kernel: md: using maximum available idle IO bandwidth (but not more than 200000 KB/sec) for data-check.
May 27 01:28:08 alexandria2 kernel: md: using 128k window, over a total of 77943740k.           
May 27 01:56:09 alexandria2 kernel: md: md1: data-check done.
May 27 01:56:15 alexandria2 kernel: md: data-check of RAID array md1

...

Looks like I'm clobberring some global variables.
Comment 5 Orion Poplawski 2012-05-30 11:19:26 EDT
Created attachment 587768 [details]
Patch to add MAXCONCURRENT to raid-check
Comment 6 Jes Sorensen 2012-05-30 11:55:35 EDT
Orion,

Thanks for the update - the new version you attached works as expected?

Cheers,
Jes
Comment 7 Orion Poplawski 2012-05-30 11:58:36 EDT
No idea - need to test it.
Comment 8 Jes Sorensen 2012-05-30 11:59:30 EDT
Ok, I'll wait for feedback from you before I start touching it.

Cheers,
Jes
Comment 9 Orion Poplawski 2012-05-31 17:30:42 EDT
Updated patch appears to work as expected, at least for the MAXCONCURRENT=1 case.
Comment 10 Tom Lavigne 2012-09-07 11:23:34 EDT
This request was evaluated by Red Hat Product Management for 
inclusion in the current release of Red Hat Enterprise Linux.
Since we are unable to provide this feature at this time,  
it has been proposed for the next release of 
Red Hat Enterprise Linux.
Comment 11 Jes Sorensen 2013-05-03 04:20:47 EDT
Ok this has been in Fedora for a long time now and nobody complained, so
lets have a look for 6.5.

Jes
Comment 16 XiaoNi 2013-10-23 04:24:19 EDT
Hi All

   I have reproduced this problem. The steps as follows:
   1. create two raid5 
   Personalities : [raid6] [raid5] [raid4] [raid1] [raid10] [raid0] 
   md1 : active raid5 sdf[3] sde[1] sdd[0]
      4191232 blocks super 1.2 level 5, 512k chunk, algorithm 2 [3/3] [UUU]
      
   md0 : active raid5 sdi[3] sdh[1] sdg[0]
      4191232 blocks super 1.2 level 5, 512k chunk, algorithm 2 [3/3] [UUU]

   2. run /usr/sbin/raid-check when MAXCONCURRENT=0
      At this condition, md0 and md1 do the check at the same time. the devices under the raid all have read io.

   3. run /usr/sbin/raid-check when MAXCONCURRENT=1
      At this condition, only one of the two raid do the check. 

   So, set verified.
Comment 17 errata-xmlrpc 2013-11-21 07:03:32 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1643.html

Note You need to log in before you can comment on or make changes to this bug.