Bug 819957 - [abrt] hplip-3.12.4-2.fc17: hp-diagnose_queues crashed due to unknown distro (F-17)
[abrt] hplip-3.12.4-2.fc17: hp-diagnose_queues crashed due to unknown distro ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
abrt_hash:e344d03c62edbf162a4894136e1...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-08 13:54 EDT by Jack Tucker
Modified: 2012-07-10 16:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-10 16:56:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jack Tucker 2012-05-08 13:54:29 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
cmdline:        /usr/bin/python /usr/bin/hp-diagnose_queues -r
executable:     /usr/bin/hp-diagnose_queues
kernel:         3.3.4-4.fc17.x86_64
time:           Tue 08 May 2012 12:52:50 PM CDT
uid:            1000
username:       jack

backtrace:
:core_install.py:437:init:KeyError: 0
:
:Traceback (most recent call last):
:  File "/usr/bin/hp-diagnose_queues", line 250, in <module>
:    core.init()
:  File "/usr/share/hplip/installer/core_install.py", line 437, in init
:    self.distro_name = self.distros_index[self.distro]
:KeyError: 0
:
:Local variables in innermost frame:
:cmdline: ''
:self: <installer.core_install.CoreInstall object at 0x1da25d0>
:pid: 0
:d: 'python2x'
:callback: None

smolt_data:
:
:
:General
:=================================
:UUID: defdfd1b-8529-4b82-bd52-04d7f4831ae8
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 5009.77
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM)2 Quad CPU    Q6600  @ 2.40GHz
:CPU Stepping: 11
:CPU Family: 6
:CPU Model Num: 15
:Number of CPUs: 4
:CPU Speed: 2403
:System Memory: 3955
:System Swap: 6015
:Vendor: MICRO-STAR INTERNATIONAL CO.,LTD
:System: P35 Platinum(MS-7345) 1.0
:Form factor: Desktop
:Kernel: 3.3.4-4.fc17.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:10688:5218:29509) pci, None, HOST/PCI, 82G33/G31/P35/P31 Express DRAM Controller
:(32902:10689:32902:0) pci, pcieport, PCI/PCI, 82G33/G31/P35/P31 Express PCI Express Root Port
:(32902:10544:5218:29509) pci, i801_smbus, SERIAL, 82801I (ICH9 Family) SMBus Controller
:(32902:10530:5218:29509) pci, ahci, STORAGE, 82801IR/IO/IH (ICH9R/DO/DH) 6 port SATA AHCI Controller
:(32902:10518:5218:29509) pci, None, PCI/ISA, 82801IR (ICH9R) LPC Interface Controller
:(32902:9294:5218:29509) pci, None, PCI/PCI, 82801 PCI Bridge
:(32902:10549:5218:29509) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #2
:(32902:10548:5218:29509) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #1
:(32902:10553:5218:29509) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #6
:(32902:10550:5218:29509) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #3
:(32902:10554:5218:29509) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #1
:(32902:10556:5218:29509) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #2
:(32902:10560:5218:29509) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 1
:(32902:10568:5218:29509) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 5
:(32902:10558:5218:29530) pci, snd_hda_intel, MULTIMEDIA, 82801I (ICH9 Family) HD Audio Controller
:(32902:10551:5218:29509) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #4
:(32902:10552:5218:29509) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #5
:(4098:43544:6023:43544) pci, snd_hda_intel, MULTIMEDIA, Radeon HD 3870 Audio device
:(4098:38149:6023:8195) pci, radeon, VIDEO, RV670PRO [Radeon HD 3850]
:(32902:10570:5218:29509) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 6
:(4358:12356:5218:13405) pci, firewire_ohci, FIREWIRE, VT6306/7/8 [Fire II(M)] IEEE 1394 OHCI Controller
:(4332:33129:4997:12570) pci, r8169, ETHERNET, GA311
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_recroom--pc-lv_root / ext4 4096 4096 10971232 9501889 8952206 2752512 2569732 2569732
:/dev/sdb1 /boot ext4 1024 1024 508745 454776 429176 128016 127728 127728
:/dev/mapper/vg_recroom--pc-lv_home /home ext4 4096 4096 5472054 5259411 4984979 1373568 1370954 1370954
:/dev/sdc1 WITHHELD fuseblk UNKNOWN UNKNOWN UNKNOWN UNKNOWN UNKNOWN UNKNOWN UNKNOWN UNKNOWN
:
Comment 1 Jiri Popelka 2012-05-09 05:51:20 EDT
The reason for this crash is that HPLIP upstream adds its own installator for distros (they keeps ignoring packaging systems of distros) and Fedora-17 is not among "supported" distros in hplip-3.12.4.

I was already investigating this particular crash in hp-diagnose_queues and there doesn't seem to be any simple solution.

Do we actually need this new hp-diagnose_queues thing ?
Comment 2 Tim Waugh 2012-05-09 10:24:37 EDT
I don't see a problem with disabling it until it actually does something useful.
Comment 3 Chresten 2012-05-24 08:32:14 EDT
switch off device

Package: hplip-3.12.4-2.fc17
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 4 david.minster 2012-06-01 03:14:41 EDT
I just want to print a document, any document.

Package: hplip-3.12.4-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 5 Larry O'Leary 2012-06-08 23:29:35 EDT
From HP Device Manager, I selected my HP Photosmart C7100 Series (Fax) device and then selected Diagnose Queues from the Actions tab.

Package: hplip-3.12.4-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 6 Silvio Schneider 2012-06-18 14:58:33 EDT
tried before installing the plugin

Package: hplip-3.12.4-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 7 Fedora Update System 2012-06-19 06:13:06 EDT
hplip-3.12.6-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/hplip-3.12.6-1.fc17
Comment 8 Fedora Update System 2012-06-19 20:35:09 EDT
Package hplip-3.12.6-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hplip-3.12.6-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-9701/hplip-3.12.6-1.fc17
then log in and leave karma (feedback).
Comment 9 Alex 2012-07-03 14:33:45 EDT
installing laser printer HP 1018 via hplip-gui (started in console as 'hp-toolbox')

Package: hplip-3.12.4-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 10 Fedora Update System 2012-07-10 16:56:55 EDT
hplip-3.12.6-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.