This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 819971 - grub2: source_dir doesn't exist.
grub2: source_dir doesn't exist.
Status: CLOSED DUPLICATE of bug 818378
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
17
i686 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-08 14:47 EDT by Marc Muehlfeld
Modified: 2012-05-08 15:10 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-08 15:10:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marc Muehlfeld 2012-05-08 14:47:33 EDT
Description of problem:
I installed F17 including all updates. After installing the packages during the setup, I got the message, that the boot loader generated an problem and the system probably won't boot, and it doesn't.

I booted the rescue system and run "grub2-install /dev/sda" what also fails.




Version-Release number of selected component (if applicable):
grub2-2.0.0.24.beta4.fc17.i686




How reproducible:
Always when trying to boot.




Steps to Reproduce:
1. Install F17 with updates
2. Already first boot (during setup) fails.



  
Actual results:
GRUB loading.
Welcome to GRUB!
error: file not found.
Entering rescue mode...
grub rescue>

anaconda.program.log:
21:46:33,293 INFO program: Running... /sbin/rsyslogd -c 4 -f /tmp/rsyslog_backend.conf -i /var/run/rsyslog_backend.pid
22:03:37,700 INFO program: Running... /usr/sbin/lokkit --selinux=enforcing
22:03:37,803 INFO program: Running... /usr/sbin/authconfig --update --nostart --enableshadow --passalgo=sha512
22:03:37,928 INFO program: Running... /usr/sbin/lokkit --quiet --nostart -f --service=ssh
22:03:38,066 INFO program: Running... grub2-set-default Fedora Linux, with Linux 3.3.4-3.fc17.i686.PAE
22:03:38,110 INFO program: Running... grub2-mkconfig -o /boot/grub2/grub.cfg
22:03:38,218 ERR program: Generating grub.cfg ...
22:03:38,398 ERR program: Found linux image: /boot/vmlinuz-3.3.4-3.fc17.i686.PAE
22:03:38,412 ERR program: Found initrd image: /boot/initramfs-3.3.4-3.fc17.i686.PAE.img
22:03:38,551 ERR program: Warning: Please don't use old title `Fedora Linux, with Linux 3.3.4-3.fc17.i686.PAE' for GRUB_DEFAULT, use `Advanced options for Fedora Linux>Fedora Linux, with Linux 3.3.4-3.fc17.i686.PAE' (for versions before 2.00) or `gnulinux-advanced-970ce9f7-e4c8-4d33-82d0-5ecb5e0c96e0>gnulinux-3.3.4-3.fc17.i686.PAE-advanced-970ce9f7-e4c8-4d33-82d0-5ecb5e0c96e0' (for 2.00 or later)
22:03:42,652 ERR program: Found Microsoft Windows XP Home Edition on /dev/sda1
22:03:42,776 ERR program: Found Windows 7 (loader) on /dev/sda2
22:03:42,894 ERR program: Found Fedora release 16 (Verne) on /dev/sdb6
22:03:43,473 ERR program: Found Fedora release 16 (Verne) on /dev/sdc6
22:03:44,069 ERR program: done
22:03:44,115 INFO program: Running... grub2-install --no-floppy /dev/sda
22:03:44,154 INFO program: source_dir doesn't exist. Please specify --target or --directory




Expected results:
System should boot




Additional info:
I only have one / partition (sda6) with ext4 for F17. I don't use a /boot partition.
Comment 1 Mads Kiilerich 2012-05-08 15:10:31 EDT
See https://bugzilla.redhat.com/show_bug.cgi?id=818378#c9 for a workaround.

*** This bug has been marked as a duplicate of bug 818378 ***

Note You need to log in before you can comment on or make changes to this bug.