Bug 819976 - remmina-plugin-vnc.so: undefined symbol: gnutls_global_init
remmina-plugin-vnc.so: undefined symbol: gnutls_global_init
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: remmina (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-08 15:12 EDT by Nathanael Noblet
Modified: 2012-06-17 18:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-17 18:22:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
linker patch (596 bytes, patch)
2012-06-04 16:13 EDT, Nathanael Noblet
no flags Details | Diff

  None (edit)
Description Nathanael Noblet 2012-05-08 15:12:14 EDT
Description of problem:
When trying to run remmina and connect to a vnc host it crashes with:
remmina-plugin-vnc.so: undefined symbol: gnutls_global_init

I'm fully up to date as of today's date

I looked in 
Version-Release number of selected component (if applicable):
remmina-plugins-rdp-1.0.0-1.fc17.x86_64
remmina-plugins-common-1.0.0-1.fc17.x86_64
remmina-plugins-vnc-1.0.0-1.fc17.x86_64
gnutls-2.12.17-1.fc17.x86_64

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
readelf --all /usr/lib64/libgnutls.so | grep global =>
   261: 0000003a32431d30    97 FUNC    GLOBAL DEFAULT   12 gnutls_global_deinit@@GNUTLS_1_4
   340: 0000003a32431ab0    10 FUNC    GLOBAL DEFAULT   12 gnutls_global_set_log_lev@@GNUTLS_1_4
   549: 0000003a32431b50   468 FUNC    GLOBAL DEFAULT   12 gnutls_global_init@@GNUTLS_1_4
   659: 0000003a32431aa0    11 FUNC    GLOBAL DEFAULT   12 gnutls_global_set_time_fu@@GNUTLS_2_12
   703: 0000003a32431ac0   139 FUNC    GLOBAL DEFAULT   12 gnutls_global_set_mem_fun@@GNUTLS_1_4
   727: 0000003a32431a90    11 FUNC    GLOBAL DEFAULT   12 gnutls_global_set_log_fun@@GNUTLS_1_4
   766: 0000003a32446700    62 FUNC    GLOBAL DEFAULT   12 gnutls_global_set_mutex@@GNUTLS_2_12

I also did a grep of ldd remmina-plugin-vnc.so and there is no linkage to gnutls so I'm not sure what is going on.
Comment 1 James Hogan 2012-05-30 18:37:46 EDT
I just upgraded to f17 with preupgrade and can confirm the exact same problem:

remmina: symbol lookup error: /usr/lib64/remmina/plugins/remmina-plugin-vnc.so: undefined symbol: gnutls_global_init

remmina.x86_64                          1.0.0-1.fc17           @anaconda-0
remmina-plugins-common.x86_64           1.0.0-1.fc17           @anaconda-0
remmina-plugins-vnc.x86_64              1.0.0-1.fc17           @fedora    
gnutls.x86_64                  2.12.17-1.fc17                  @anaconda-0
Comment 2 Michael Greenberg 2012-06-04 14:29:41 EDT
Same problem here with Fedora 17:

remmina: symbol lookup error: /usr/lib64/remmina/plugins/remmina-plugin-vnc.so: undefined symbol: gnutls_global_init

remmina-plugins-vnc-1.0.0-1.fc17.x86_64
remmina-1.0.0-1.fc17.x86_64
remmina-plugins-common-1.0.0-1.fc17.x86_64
Comment 3 Christoph Wickert 2012-06-04 14:43:33 EDT
Can you please try 1.0.0-3 from updates-testing?
Comment 4 Nathanael Noblet 2012-06-04 14:46:13 EDT
No change - same error


[gnat@iridium ~]$ remmina 
Remmina plugin VNC (type=Protocol) registered.
Remmina plugin VNCI (type=Protocol) registered.
Remmina plugin RDP (type=Protocol) registered.
Remmina plugin RDPF (type=File) registered.
Remmina plugin RDPS (type=Preference) registered.
Remmina plugin SFTP (type=Protocol) registered.
Remmina plugin SSH (type=Protocol) registered.
remmina: symbol lookup error: /usr/lib64/remmina/plugins/remmina-plugin-vnc.so: undefined symbol: gnutls_global_init
[gnat@iridium ~]$
Comment 5 Nathanael Noblet 2012-06-04 16:13:23 EDT
Created attachment 589271 [details]
linker patch
Comment 6 Nathanael Noblet 2012-06-04 16:15:44 EDT
The error stems from not explicitly stating the linker requirements. This is because of this[1] change. I've also checked that it properly makes remmina-plugins-vnc require gnutls without having to modify your spec file at all. Should be safe to apply and build.



[1]http://fedoraproject.org/wiki/UnderstandingDSOLinkChange
Comment 7 James Hogan 2012-06-08 16:06:43 EDT
Thanks, I rebuilt remmina rpms with your patch Nathanael and can confirm that it fixes the problem for me.
Comment 8 Christoph Wickert 2012-06-09 14:34:27 EDT
Thanks for the patch. I wonder why it built without it, but that is probably just some cmake foo I'm not going to understand.

Update is coming your way, stay tuned.
Comment 9 Fedora Update System 2012-06-09 14:36:12 EDT
remmina-1.0.0-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/remmina-1.0.0-4.fc17
Comment 10 Fedora Update System 2012-06-09 21:36:07 EDT
Package remmina-1.0.0-4.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing remmina-1.0.0-4.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-9219/remmina-1.0.0-4.fc17
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2012-06-17 18:22:13 EDT
remmina-1.0.0-4.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.