Bug 820 - Invalid NFS writes on 2.1.x & 2.2-preX running in milti-processor mode
Invalid NFS writes on 2.1.x & 2.2-preX running in milti-processor mode
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
5.2
i386 Linux
high Severity high
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-01-13 13:38 EST by eliot
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-04-09 20:21:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description eliot 1999-01-13 13:38:14 EST
I can reliably reproduce an error that looks like a
kernel concurrency bug in NFS when building our Smalltalk
virtual machine.

The virtual machine is a 220k line C program producing 138
.o files.  On each of the 2.1.x and the 2.2.0-pre6 kernels
we have tried when running on a quad processor 180MHz
Pentium Pro box the build fails if the build directory is
remote-munted over NFS.  The compiler produces a number of
invalid .o's which cause the link to fail.

When running exactly the same make where the build directory
is a ext2fs system on a local disc the build succeeds.

On various 2.1.x kernels I have also seen random occurrences
of nulls appearing in a dependency file generated early in
the make.  In all cases one to four nulls appeared on the
4096 byte boundary.  This bug seems to have been cured by
2.2.0-pre6, but from the above there still seem to be
problems with NFS running in multi-processor mode.
Comment 1 Preston Brown 1999-03-29 16:13:59 EST
Have you seen this problem in the 2.2.4 or 2.2.5 kernels?
Comment 2 Michael K. Johnson 1999-04-09 20:21:59 EDT
The latest kernels have patches that caused Linux to pass
the tests at connectathon, as well as lots and lots of other
work on NFS.  I'm closing this report (which is against a kernel
we never shipped in the first place...) and if you can reproduce
it with the latest kernel, feel free to reopen it with information
on which new kernel kernel (including a complete list of patches
that you have applied) you are using.

Note You need to log in before you can comment on or make changes to this bug.