Bug 820007 - ipa-client-install : run as non-root user outputs many debug message
ipa-client-install : run as non-root user outputs many debug message
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Rob Crittenden
IDM QE LIST
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-08 16:59 EDT by Yi Zhang
Modified: 2013-09-04 13:50 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-18 11:37:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yi Zhang 2012-05-08 16:59:23 EDT
Description of problem:
[yi@aqua (RH5.8-i386) ~] ipa-client-install 
Traceback (most recent call last):
  File "/usr/sbin/ipa-client-install", line 1289, in ?
    sys.exit(main())
  File "/usr/sbin/ipa-client-install", line 1254, in main
    logging_setup(options)
  File "/usr/sbin/ipa-client-install", line 145, in logging_setup
    filemode='w')
  File "/usr/lib/python2.4/logging/__init__.py", line 1218, in basicConfig
    hdlr = FileHandler(filename, mode)
  File "/usr/lib/python2.4/logging/__init__.py", line 757, in __init__
    stream = open(filename, mode)
IOError: [Errno 13] Permission denied: '/var/log/ipaclient-install.log'


Version-Release number of selected component (if applicable): ipa-client-2.1.3-2.el5_8


How reproducible: always


Steps to Reproduce:
1. build is from here: https://brewweb.devel.redhat.com/buildinfo?buildID=213082
2. yum localinstall ipa-client.rpm
3. run "ipa-client-install" as non-root user
Comment 2 Martin Kosek 2012-05-09 04:13:37 EDT
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/2738
Comment 4 Scott Poore 2012-06-27 11:46:56 EDT
Is this being considered for a fix in RHEL5.8.z?  or 5.9.z in the future? or just too late for RHEL5?
Comment 6 Martin Kosek 2012-09-18 03:12:25 EDT
Ticket 2738 was closed as a duplicate of https://fedorahosted.org/freeipa/ticket/957 which was already fixed upstream:

master: 856d890bb37a9a793fdcbe0884d1e7286aeec1f5
Comment 8 Dmitri Pal 2012-09-18 11:37:15 EDT
This issues already addressed in the current shipping version. There is no plan to backport it so we are closing this bug as already addressed.

Note You need to log in before you can comment on or make changes to this bug.