Bug 820014 - switch to dnspython to fix current and future build failures
switch to dnspython to fix current and future build failures
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.0
Unspecified Unspecified
medium Severity unspecified
: rc
: ---
Assigned To: Rob Crittenden
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-08 17:52 EDT by Rob Crittenden
Modified: 2014-06-17 20:02 EDT (History)
3 users (show)

See Also:
Fixed In Version: ipa-3.2.1-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 07:31:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob Crittenden 2012-05-08 17:52:58 EDT
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/freeipa/ticket/2730

Looks like something in authconfig changed.

{{{
Traceback (most recent call last):
  File "./makeapi", line 30, in <module>
    from ipalib import api
  File "/builddir/build/BUILD/freeipa-2.2.0/ipalib/__init__.py", line 876, in <module>
    import plugable
  File "/builddir/build/BUILD/freeipa-2.2.0/ipalib/plugable.py", line 38, in <module>
    import util
  File "/builddir/build/BUILD/freeipa-2.2.0/ipalib/util.py", line 35, in <module>
    from ipapython import dnsclient
  File "/builddir/build/BUILD/freeipa-2.2.0/ipapython/dnsclient.py", line 21, in <module>
    import acutil
ImportError: /usr/lib/python2.7/site-packages/acutilmodule.so: undefined symbol: __res_send
}}}

regression testing only
Comment 4 Martin Kosek 2012-05-24 07:57:45 EDT
Fixed upstream:
master: https://fedorahosted.org/freeipa/changeset/f1ed123caddd7525a0081c4a9de931cabdfda43f

IPA now uses python-dns for DNS lookup operations.
Comment 8 Scott Poore 2014-01-29 15:18:38 EST
Verified.

Version ::

ipa-server-3.3.3-15.el7.x86_64

Test Results ::

[root@rhel7-4 ~]# rpm -qR ipa-server | grep  authconfig
[root@rhel7-4 ~]# rpm -qR ipa-server | grep  python-dns
python-dns

[root@rhel7-4 ~]# grep Restart.*python-dns /usr/sbin/ipa-dns-install
    # Restart http instance to make sure that python-dns has the right resolver
Comment 9 Ludek Smid 2014-06-13 07:31:29 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.