Bug 820020 - suboptimal default max_block_size for 32-bit
suboptimal default max_block_size for 32-bit
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.3
Unspecified Linux
unspecified Severity medium
: rc
: ---
Assigned To: J. Bruce Fields
Filesystem QE
:
Depends On: 820019
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-08 18:32 EDT by J. Bruce Fields
Modified: 2013-03-03 19:22 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 820019
Environment:
Last Closed: 2012-10-03 13:00:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description J. Bruce Fields 2012-05-08 18:32:09 EDT
+++ This bug was initially created as a clone of Bug #820019 +++

When we extended nfsd's maximum IO size to 1MB, the servers configured with lots of nfsd threads started failing to create them all, because more memory was then required per thread.

For the short term we decided to document the change and allow people to manually adjust the maximum IO size.

However as noticed at
https://bugzilla.redhat.com/show_bug.cgi?id=765751#c21

we'd get a more reasonable defaults on 32-bit servers if the heuristic used to choose a default maximum IO size was based on the amount of low memory available instead of on the total amount of RAM available.

Patches doing this have since gone upstream: 508f92275624fc755104b17945bdc822936f1918 "nfsd: fix default iosize calculation on 32bit" and 87b0fc7deb5feccf93b022f6a976e8441152dbb2 "nfsd: cleanup setting of default max_block_size".
Comment 1 RHEL Product and Program Management 2012-06-27 09:50:15 EDT
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.
Comment 2 J. Bruce Fields 2012-10-03 13:00:41 EDT
This can decrease the maximum IO size on upgrade.  A few upstream users have reported problems when the upgrade without remounting clients: in that case, clients will continue trying to use the old (larger) IO size but the server will drop those (now too-large) requests.

We could do something more sophisticated.

For now let's leave the rhel6 behavior alone.  We can reconsider if it turns out to be a problem for someone.

Note You need to log in before you can comment on or make changes to this bug.