Bug 820030 - [ja_JP] [RHSM CLI] config module --help message some strings displayed as question mark.
[ja_JP] [RHSM CLI] config module --help message some strings displayed as que...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.3
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Adrian Likins
Entitlement Bugs
: i18n, Translation
Depends On: 773535
Blocks: 738066
  Show dependency treegraph
 
Reported: 2012-05-08 20:11 EDT by Lijun Li
Modified: 2012-06-20 08:57 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 773535
Environment:
Last Closed: 2012-06-20 08:57:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lijun Li 2012-05-08 20:11:28 EDT
It's reproduced on subscription-manager-0.99.16-1.el6.x86_64.


+++ This bug was initially created as a clone of Bug #773535 +++

Description of problem:
config module --help message some strings displayed as question mark.

Version-Release number of selected component (if applicable):
subscription-manager-0.98.10-1.el5


How reproducible:
100%

Steps to Reproduce:
1. Install rhel5.8 snapshot-3 OS build via
http://download.englab.nay.redhat.com/pub/rhel/rel-eng/RHEL5.8-Server-20120105.0/5/i386/os/

2. (Display help)

$ sudo subscription-manager config --help

  
Actual results:
Some strings displayed as question mark in config help message.

Expected results:
All the strings should be displayed correctly.

Additional info:

--- Additional comment from lijli@redhat.com on 2012-01-12 02:37:01 EST ---

Created attachment 552329 [details]
some strings displayed as question mark

--- Additional comment from lijli@redhat.com on 2012-02-10 00:42:22 EST ---

It's reproduced on subscription-manager-0.98.14-1.el5 too

--- Additional comment from lijli@redhat.com on 2012-02-10 00:43:15 EST ---

Created attachment 560778 [details]
some strings displayed as question mark
Comment 2 Adrian Likins 2012-05-10 10:37:31 EDT
commit aa2020706aedac193f5f869f16610c43694ac3c5
Author: Adrian Likins <alikins@redhat.com>
Date:   Wed May 9 11:39:29 2012 -0400

    820040,820037,820030: don't break multibyte help blurbs
    
    Add a optparse.HelpFormatter subclass that includes
    a version of format_option that does not try to split
    long words.This behavior is broken for multibyte cases.
    
    This includes code cut&paste from optparse.py in
    the python dist.

Should show up in 0.99.18
Comment 6 Lijun Li 2012-05-18 03:16:25 EDT
Verified, it's fixed on subscription-manager-0.99.18-1.el6.x86_64.
Comment 8 errata-xmlrpc 2012-06-20 08:57:23 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0804.html

Note You need to log in before you can comment on or make changes to this bug.