Bug 820034 - (CVE-2012-2330) CVE-2012-2330 node.js: HTTP Server Parser Buffer information disclosure
CVE-2012-2330 node.js: HTTP Server Parser Buffer information disclosure
Status: CLOSED ERRATA
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Product Security
impact=moderate,public=20120507,repor...
: Security
Depends On: 885976
Blocks: 767033
  Show dependency treegraph
 
Reported: 2012-05-08 20:23 EDT by Kurt Seifried
Modified: 2016-11-08 10:49 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-15 23:46:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kurt Seifried 2012-05-08 20:23:38 EDT
http://blog.nodejs.org/2012/05/07/http-server-security-vulnerability-please-upgrade-to-0-6-17/

A carefully crafted attack request can cause the contents of the HTTP parser’s buffer to be appended to the attacking request’s header, making it appear to come from the attacker. Since it is generally safe to echo back contents of a request, this can allow an attacker to get an otherwise correctly designed server to divulge information about other requests. It is theoretically possible that it could enable header-spoofing attacks, though such an attack has not been demonstrated.

Versions affected: All versions of the 0.5/0.6 branch prior to 0.6.17, and all versions of the 0.7 branch prior to 0.7.8. Versions in the 0.4 branch are not affected.

Fix: Upgrade to v0.6.17, or apply the fix in c9a231d to your system.
Comment 2 Rob Millner 2012-12-11 13:04:10 EST
NodeJS version 0.6.20 is installed on OpenShift.

# rpm -q nodejs
nodejs-0.6.20-1.el6_3.x86_64

Note You need to log in before you can comment on or make changes to this bug.