Bug 820088 - yum-builddep kernel missing asciidoc
yum-builddep kernel missing asciidoc
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: asciidoc (Show other bugs)
6.2
All Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Chris Wright
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-09 02:35 EDT by Jesper Brouer
Modified: 2013-01-09 19:56 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-10 17:25:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesper Brouer 2012-05-09 02:35:27 EDT
Description of problem:

 Default RHEL6.2 server install seems to be missing asciidoc.

 asciidoc is needed to fulfill yum build-dependencies for the kernel.
 e.g. run:
 "yum-builddep kernel"


Version-Release number of selected component (if applicable):

 lsb_release -d -r -c
 Description:    Red Hat Enterprise Linux Server release 6.2 (Santiago)
 Release:        6.2
 Codename:       Santiago


How reproducible:

 100% on my freshly installed RHEL6.2 server.

Steps to Reproduce:
1. Run: "yum-builddep kernel"
2. Or run: yum install asciidoc
3.
  
Actual results:

 yum-builddep kernel
 Error: No Package found for asciidoc
 (and none of the other builddep RPMs are installed)

Expected results:

 The builddep RPMs would be installed.

Additional info:

 What RPM repository do I need to enable to get asciidoc installed?
Comment 2 Jesper Brouer 2012-05-09 03:22:44 EDT
Workaround:
-----------
Used RPMforge repository to find RPM for asciidoc.
 http://wiki.centos.org/AdditionalResources/Repositories/RPMForge

Install DAG's GPG key::
 rpm --import http://apt.sw.be/RPM-GPG-KEY.dag.txt

Install 64-bit version::
 rpm -Uvh \
  http://packages.sw.be/rpmforge-release/rpmforge-release-0.5.2-2.el6.rf.x86_64.rpm

Optionally limit packages to asciidoc, by editing
/etc/yum.repos.d/rpmforge.repo and adding::

  # Edit file: /etc/yum.repos.d/rpmforge.repo
  # add:
  includepkgs=asciidoc

The asciidoc package is in the "rpmforge-extras" repository, which is
not enabled by default.  Its possible to enable on the command line via::

 yum install --enablerepo=rpmforge-extras asciidoc
Comment 3 Jesper Brouer 2012-05-16 03:39:01 EDT
It looks like asciidoc is also avail in the optional repo.

Install command:
  yum --enablerepo=rhel-6-server-optional-beta-rpms install asciidoc

To enable the optional repo permanently, you can edited /etc/yum.repos.d/redhat.repo and under section [rhel-6-server-optional-beta-rpms] changed enabled = 1.
Comment 4 RHEL Product and Program Management 2012-09-07 01:37:28 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 5 Chris Wright 2012-09-10 17:25:20 EDT
AFAIK, this is working as intended.  The optional repo is for things that may not have the same support, but are needed for build deps, etc.
Comment 6 Jesper Brouer 2012-09-10 17:31:27 EDT
Yes, this is working as intended, as the package is avail in "rhel-6-server-optional-beta-rpms".

Note You need to log in before you can comment on or make changes to this bug.