Bug 820127 - Boot from CD doesn't work on 3.1 compatibility
Boot from CD doesn't work on 3.1 compatibility
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-core (Show other bugs)
unspecified
Unspecified Unspecified
urgent Severity high
: ---
: 3.1
Assigned To: Eli Mesika
virt
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-09 04:54 EDT by Mike Kolesnik
Modified: 2012-08-09 03:58 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 823910 828327 (view as bug list)
Environment:
Last Closed: 2012-08-09 03:58:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Kolesnik 2012-05-09 04:54:08 EDT
Description of problem:
VMs created in a 3.1 cluster cannot be booted from CD.

The cause is that createVm command is sent to VDSM with only the ISO filename as path, but should be sent with full path.


Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. Create a VM
2. Edit the VM to boot from a CD and select an ISO
3. Run the VM (not run-once)
  
Actual results:
The VM fails to load the ISO image, from VDSM log:
Thread-77::DEBUG::2012-05-09 10:26:55,836::libvirtvm::993::vm.Vm::(__init__) vmId=`ba9147c9-890a-44ec-8aaa-7bcdd9814ba3`::removable device not found in Fedora-16-i686-Live-Desktop.iso


Expected results:
The VM should load the ISO image


Additional info:
Happens on RHEL6.3 host..
Does not happen on 3.0 compatibility version with F16 host.
Comment 1 Eli Mesika 2012-05-13 10:57:59 EDT
http://gerrit.ovirt.org/#change,4378
Comment 2 Oded Ramraz 2012-05-16 16:16:51 EDT
Blocks our Windows guests installation unattended tests
Comment 3 Itamar Heim 2012-08-09 03:58:12 EDT
closing ON_QA bugs as oVirt 3.1 was released:
http://www.ovirt.org/get-ovirt/

Note You need to log in before you can comment on or make changes to this bug.