Bug 820170 - [RFE]Subscription-manager release –list command should display “not supported” msg for older candlepin.
[RFE]Subscription-manager release –list command should display “not supported...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: William Poteat
Entitlement Bugs
: QA-Closed
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-05-09 06:20 EDT by spandey
Modified: 2015-04-23 19:57 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-09 12:46:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description spandey 2012-05-09 06:20:06 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


subscription-manager-0.99.16-1.git.2.4a2634a.el6_2.x86_64
subscription-manager-migration-0.99.16-1.git.2.4a2634a.el6_2.x86_64
subscription-manager-firstboot-0.99.16-1.git.2.4a2634a.el6_2.x86_64
subscription-manager-gnome-0.99.16-1.git.2.4a2634a.el6_2.x86_64
subscription-manager-migration-data-1.12.1.8-1.git.0.c91a246.el6_2.noarch

Steps to verify : 
Registered client to older candlepin i used (10.65.201.177).
execute following command on client console.

subscription-manager release –list

Expected Result :
Following message should display on  console. 
ERROR: The 'release' command is not supported by the server.

Actual Result : 
[root@sachbeta1 ~]# subscription-manager release --list
[root@sachbeta1 ~]# echo $?
0

Working fine with release , and release –set 
[root@sachbeta1 ~]# subscription-manager release 
ERROR: The 'release' command is not supported by the server.
[root@sachbeta1 ~]# subscription-manager release --set=2303030303003
ERROR: The 'release' command is not supported by the server.
Comment 1 William Poteat 2012-05-17 07:53:41 EDT
master commit 999959c3c7906f09664cf2ccb7b97c412be71aad
Comment 2 spandey 2012-06-21 07:03:42 EDT
Verified using following rpm 

subscription-manager-migration-data-1.11.1.1-1.git.2.c7fbafe.el5
subscription-manager-gui-1.0.4-1.git.0.5943ee7.el5
subscription-manager-migration-1.0.4-1.git.0.5943ee7.el5
subscription-manager-firstboot-1.0.4-1.git.0.5943ee7.el5
subscription-manager-1.0.4-1.git.0.5943ee7.el5


displaying proper message 
[root@dhcp201-115 ~]# subscription-manager release --list
Error: The 'release' command is not supported by the server.

Resolving defect as verified
Comment 3 Bryan Kearney 2013-01-09 12:46:27 EST
Batch change of verified bugs which must have missed making the errata.

Note You need to log in before you can comment on or make changes to this bug.