Bug 820211 - wireless stopped working in kernel-3.3.2-6.fc16.x86_6
wireless stopped working in kernel-3.3.2-6.fc16.x86_6
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-09 07:56 EDT by Tom Horsley
Modified: 2012-05-14 10:54 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-14 10:54:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg from working 3.3.2-1 kernel (53.91 KB, text/plain)
2012-05-09 07:59 EDT, Tom Horsley
no flags Details
dmesg from failing kernel 3.3.4-3 (53.63 KB, text/plain)
2012-05-09 08:11 EDT, Tom Horsley
no flags Details

  None (edit)
Description Tom Horsley 2012-05-09 07:56:19 EDT
Description of problem:

I'm using a USB dongle as a wireless access point via hostapd:
Bus 001 Device 004: ID 050d:705a Belkin Components F5D7050 Wireless G Adapter
v3000 [Ralink RT2573]

Bug 716988 was just closed because my USB dongle started working 1st time
every time. Unfortunately, that was short lived. I've just tried booting all
three kernels on my machine, and kernel-3.3.2-6.fc16.x86_64 and kernel-3.3.4-3.fc16.x86_64 both fail to work. The oldest kernel kernel-3.3.2-1.fc16.x86_64 works perfectly.

The failure mode is completely different now though. Everything appears to
work fine. I get connected, I even get assigned an IP by my DHCP server, all
NAT iptables rules seem to be setup correctly, etc. Unfortunately, no
traffic makes it through the interface. I can't even talk directly to my
desktop which is the gateway, much less talk to anything in the outside world.

Version-Release number of selected component (if applicable):
kernel-3.3.2-6.fc16.x86_64 and kernel-3.3.4-3.fc16.x86_64

How reproducible:
Seems 100%, it apparently connects successfully, yet fails to talk every time
I try on the newer kernels.

Steps to Reproduce:
1. see above
  
Actual results:
No traffic via wlan0

Expected results:
Talking to the internet normally.

Additional info:

I'm not using NetworkManager, I starting things up "by hand". Here's the
script that starts the access point running once I plug in the USB dongle:

#!/bin/sh
#
# Run as root - brings up the access point
#
ifconfig wlan0 netmask 255.255.255.0 192.168.9.1
sleep 1
service iptables start
sleep 1
service hostapd start
sleep 1
systemctl start dhcpd.service

Here's the /etc/sysconfig/iptables used to do the NATting:

# Generated by iptables-save v1.4.9 on Fri May 20 09:58:26 2011
*nat
:PREROUTING ACCEPT [34:2176]
:OUTPUT ACCEPT [55:4168]
:POSTROUTING ACCEPT [55:4168]
-A POSTROUTING -o em1 -j MASQUERADE 
COMMIT
# Completed on Fri May 20 09:58:26 2011
# Generated by iptables-save v1.4.9 on Fri May 20 09:58:26 2011
*filter
:INPUT ACCEPT [392008:153506294]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [364620:51248845]
COMMIT
# Completed on Fri May 20 09:58:26 2011

And here's the hostapd.conf file with password and ssid hidden:

ctrl_interface=/var/run/hostapd
ctrl_interface_group=root
macaddr_acl=0
auth_algs=1
ignore_broadcast_ssid=1
wpa=2
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP
rsn_pairwise=CCMP
wpa_passphrase=**********
driver=nl80211
interface=wlan0
hw_mode=g
channel=11
ssid=*******
Comment 1 Tom Horsley 2012-05-09 07:59:31 EDT
Created attachment 583246 [details]
dmesg from working 3.3.2-1 kernel
Comment 2 Tom Horsley 2012-05-09 08:11:30 EDT
Created attachment 583253 [details]
dmesg from failing kernel 3.3.4-3

I said above that I always connected, but couldn't ever actually talk, but now that I've rebooted back into the latest kernel 3.3.4-3, I can't get connected at all. This is the dmesg following that connect attempt.
Comment 3 Tom Horsley 2012-05-14 07:34:55 EDT
I just got kernel-3.3.5-2.fc16.x86_64 this morning and tried my USB dongle again,
and it appears to be working once more. I connected on my first attempt, and
it can ping outside sites, and access outside web sites. So maybe whatever broke
has now been fixed.
Comment 4 Josh Boyer 2012-05-14 10:54:30 EDT
Thanks for letting us know.  If you have issues again, please reopen.

Note You need to log in before you can comment on or make changes to this bug.