Bug 820232 - [RHEVM] [backend] [Setup Host Networks] variables not substituted in error message
[RHEVM] [backend] [Setup Host Networks] variables not substituted in error me...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Alona Kaplan
Martin Pavlik
network
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-09 08:43 EDT by Martin Pavlik
Modified: 2016-02-10 14:59 EST (History)
10 users (show)

See Also:
Fixed In Version: si8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:06:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
incorrect error message (124.87 KB, image/png)
2012-05-09 08:43 EDT, Martin Pavlik
no flags Details

  None (edit)
Description Martin Pavlik 2012-05-09 08:43:09 EDT
Created attachment 583264 [details]
incorrect error message

Description of problem:

Error message which appears after editing network interface on active host does not have correct substitutions


Message looks like this:

Error:

dell-r210ii-05:

    Cannot ${action} ${type}. Host parameters cannot be modified while Host is operational.
    Please switch Host to Maintenance mode first.


${action} ${type} should be replaced with proper content


Version-Release number of selected component (if applicable):
oVirt Enterprise Virtualization Engine Manager Version: 3.1.0_0001-9.el6ev 

How reproducible:
always

Steps to Reproduce:
Host should be active

1) Go to Hosts -> your host -> Network Interface -> Setup Host Network
2) click on the "pencil icon" on rhevm NIC (ie em1)
   a) change Boot Protocol from DHCP to static or vice versa
   b) click OK
3) click OK
4) Error message appears

   
Actual results:
Error message contains variables ${action} ${type}


Expected results:
${action} ${type} should be replaced with proper content


Additional info:
screenshost attached
Comment 1 Yaniv Kaul 2012-05-09 08:51:44 EDT
Setting Regression - we did not have such errors in 3.0.
Comment 3 Moti Asayag 2012-07-26 02:52:26 EDT
fixed by commit-id 305fd6ad851b7f9a5271f6efb2e41cf38b30e892
Comment 4 Martin Pavlik 2012-07-27 09:10:17 EDT
I tried to verify this bug, but now there is no error message at all, settings of rhevm interface just get changed from static to DHCP and vice versa, is that a bug or a feature?
Comment 5 Moti Asayag 2012-07-28 08:55:19 EDT
This is a feature as a result of Bug 826470: The setup networks is applicable for host's statuses: UP, Maintenance or Non-operational.

You can verify the error message by manipulating the host into other status than the mentioned above and run the setup-networks command for it (I think the easiest way is moving the host to NonResponsive by loosing connectivity to it or to Unassigned when activating it - but Unassinged leaves a short time frame to act).

Note You need to log in before you can comment on or make changes to this bug.