Bug 820258 - Change in winSyncInterval does not take immediate effect
Summary: Change in winSyncInterval does not take immediate effect
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: 389-ds-base
Version: 7.0
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: rc
: 7.0
Assignee: Rich Megginson
QA Contact: Sankar Ramalingam
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-05-09 13:35 UTC by Steeve Goveas
Modified: 2020-09-13 20:12 UTC (History)
4 users (show)

Fixed In Version: 389-ds-base-1.3.1.2-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-13 13:24:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github 389ds 389-ds-base issues 393 0 None None None 2020-09-13 20:12:45 UTC

Description Steeve Goveas 2012-05-09 13:35:28 UTC
Description of problem:
Change in winSyncInterval does not take immediate effect


Version-Release number of selected component (if applicable):
389-ds-base-1.2.10.2-6.el6.x86_64

How reproducible: Always


Steps to Reproduce:
1. Configure AD winsync

2. Update errorlog level of 389-ds config to 8192
nsslapd-errorlog-level: 8192

3. Modify winsync interval to 120 seconds

4. Observe the error logs for timestamp of "Running Dirsync"
eg:
tail -f /var/log/dirsrv/slapd-LAB-ENG-PNQ-REDHAT-COM/errors | grep "Running Dirsync"

  
Actual results:
Dirsync is initiated at default 300 seconds interval. The new interval doesn't take effect unless dirsrv is restarted.

Expected results:
winSyncInterval change should take effect immediately without restart.


Additional info:
Last night I had changed the interval to 600 seconds. Today I set it to 120 seconds and watched the logs to check when the interval change would take effect. After more than an hour I restarted only dirsrv this time.

[root@wheeljack ~]# date; ldapmodify -x -D "cn=directory manager" -w wheeljack << EOF
dn: cn=meTodhcp201-118.englab.pnq.redhat.com,cn=replica,cn=dc\3Dlab\2Cdc\3Deng\2Cdc\3Dpnq\2Cdc\3Dredhat\2Cdc\3Dcom,cn=mapping tree,cn=config
changetype: modify
replace: winSyncInterval
winSyncInterval: 120
EOF

Wed May  9 12:16:06 IST 2012
modifying entry "cn=meTodhcp201-118.englab.pnq.redhat.com,cn=replica,cn=dc\3Dlab\2Cdc\3Deng\2Cdc\3Dpnq\2Cdc\3Dredhat\2Cdc\3Dcom,cn=mapping tree,cn=config"

[root@wheeljack ~]# date; service dirsrv restart
Wed May  9 13:30:38 IST 2012
Shutting down dirsrv:
    LAB-ENG-PNQ-REDHAT-COM...                              [  OK  ]
    PKI-IPA...                                             [  OK  ]
Starting dirsrv:
    LAB-ENG-PNQ-REDHAT-COM...                              [  OK  ]
    PKI-IPA...                                             [  OK  ]
[root@wheeljack ~]#

[root@wheeljack ~]# tail -f /var/log/dirsrv/slapd-LAB-ENG-PNQ-REDHAT-COM/errors | grep "Running Dirsync"
[09/May/2012:12:10:24 +051800] NSMMReplicationPlugin - Running Dirsync
[09/May/2012:12:20:24 +051800] NSMMReplicationPlugin - Running Dirsync
[09/May/2012:12:30:24 +051800] NSMMReplicationPlugin - Running Dirsync
[09/May/2012:12:40:24 +051800] NSMMReplicationPlugin - Running Dirsync
[09/May/2012:12:50:24 +051800] NSMMReplicationPlugin - Running Dirsync
[09/May/2012:13:00:24 +051800] NSMMReplicationPlugin - Running Dirsync
[09/May/2012:13:10:24 +051800] NSMMReplicationPlugin - Running Dirsync
[09/May/2012:13:20:24 +051800] NSMMReplicationPlugin - Running Dirsync
[09/May/2012:13:30:24 +051800] NSMMReplicationPlugin - Running Dirsync
>>[09/May/2012:13:30:44 +051800] NSMMReplicationPlugin - Running Dirsync
[09/May/2012:13:32:44 +051800] NSMMReplicationPlugin - Running Dirsync
[09/May/2012:13:34:44 +051800] NSMMReplicationPlugin - Running Dirsync
[09/May/2012:13:36:44 +051800] NSMMReplicationPlugin - Running Dirsync
[09/May/2012:13:38:44 +051800] NSMMReplicationPlugin - Running Dirsync

Comment 2 RHEL Program Management 2012-05-13 04:04:30 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 3 Rich Megginson 2012-06-20 20:55:51 UTC
Upstream ticket:
https://fedorahosted.org/389/ticket/393

Comment 4 Rich Megginson 2013-10-01 23:24:48 UTC
moving all ON_QA bugs to MODIFIED in order to add them to the errata (can't add bugs in the ON_QA state to an errata).  When the errata is created, the bugs should be automatically moved back to ON_QA.

Comment 6 Sankar Ramalingam 2013-12-20 11:13:47 UTC
Hi Steeve, Requesting you to verify bugzilla from the IPA's automated test runs.

Comment 7 Sankar Ramalingam 2013-12-20 12:47:22 UTC
Clearing the NEED_INFO flag since the request is also sent by email.

Comment 8 Steeve Goveas 2013-12-20 13:09:55 UTC
:: [   PASS   ] :: Creating error log ldif file (Expected 0, got 0)
modifying entry "cn=config"

:: [   PASS   ] :: Setting the error log level (Expected 0, got 0)
:: [   PASS   ] :: Creating sync interval ldif file (Expected 0, got 0)
modifying entry "cn=meTosquab.adrelm.com,cn=replica,cn=dc\3Dtestrelm\2Cdc\3Dcom,cn=mapping tree,cn=config"

:: [   PASS   ] :: Change winsync interval to 30 seconds (Expected 0, got 0)
:: [   PASS   ] :: Waiting for new interval logs (Expected 0, got 0)
:: [   PASS   ] :: Running 'grep "Running Dirsync" /var/log/dirsrv/slapd-TESTRELM-COM/errors | tail -n2 > /tmp/tmp.J3C2YukU34/tmpout.ipa_winsync_bz820258.out 2>&1' (Expected 0, got 0)
[26/Nov/2013:10:01:15 -0500] NSMMReplicationPlugin - Running Dirsync 
[26/Nov/2013:10:01:45 -0500] NSMMReplicationPlugin - Running Dirsync 
01
01
:: [   PASS   ] :: Running 'z=0' (Expected 0, got 0)
0
15
45
:: [   PASS   ] :: Running 't=30' (Expected 0, got 0)
30
:: [   PASS   ] :: Creating file to avoid dirsrv restarts in future tests (Expected 0, got 0)
:: [   PASS   ] :: Winsync Interval successfully modified to 30 Seconds. bz820258 not found 

* Re-modify

:: [   PASS   ] :: Creating sync interval ldif file (Expected 0, got 0)
modifying entry "cn=meTosquab.adrelm.com,cn=replica,cn=dc\3Dtestrelm\2Cdc\3Dcom,cn=mapping tree,cn=config"

:: [   PASS   ] :: Replace winsync interval to 35 seconds (Expected 0, got 0)
:: [   PASS   ] :: Waiting for new interval logs (Expected 0, got 0)
:: [   PASS   ] :: Running 'grep "Running Dirsync" /var/log/dirsrv/slapd-TESTRELM-COM/errors | tail -n2 > /tmp/tmp.J3C2YukU34/tmpout.ipa_winsync_0022.out 2>&1' (Expected 0, got 0)
[26/Nov/2013:10:21:52 -0500] NSMMReplicationPlugin - Running Dirsync 
[26/Nov/2013:10:22:27 -0500] NSMMReplicationPlugin - Running Dirsync 
52
27
87
:: [   PASS   ] :: Running 'r=35' (Expected 0, got 0)
35
:: [   PASS   ] :: Winsync Interval successfully re-modified to 35 Seconds 

* Verified in version
389-ds-base-1.3.1.6-10.el7.x86_64
ipa-server-3.3.3-5.el7.x86_64

Comment 9 Ludek Smid 2014-06-13 13:24:49 UTC
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.


Note You need to log in before you can comment on or make changes to this bug.