Bug 820264 - livecd-iso-to-pxeboot doesn't work with Fedora 17
livecd-iso-to-pxeboot doesn't work with Fedora 17
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-09 09:42 EDT by Kamil Páral
Modified: 2012-05-17 16:31 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-16 12:44:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel panic screenshot (1.27 MB, image/jpeg)
2012-05-09 09:42 EDT, Kamil Páral
no flags Details
kernel panic with F17 TC6 (1.36 MB, image/jpeg)
2012-05-16 07:29 EDT, Kamil Páral
no flags Details
another panic with TC6 (1.24 MB, image/jpeg)
2012-05-16 07:41 EDT, Kamil Páral
no flags Details
This patch makes the traceback slightly more reasonable. (1.23 KB, patch)
2012-05-16 13:48 EDT, Peter Jones
no flags Details | Diff

  None (edit)
Description Kamil Páral 2012-05-09 09:42:36 EDT
Created attachment 583287 [details]
kernel panic screenshot

Description of problem:
I tried to create a bootable PXE entries for Fedora 17 TC3 Live i686. But during boot I receive kernel panic, see screenshot.

I used the config created by livecd-iso-to-pxeboot:

LABEL Fedora 17 TC3 i686 Live (EXPERIMENTAL)
        KERNEL vmlinuz0
        INITRD initrd0.img
        APPEND rootflags=loop root=live:/Fedora-17.TC3-i686-Live-Desktop.iso rootfstype=auto ro liveimg quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0

Version-Release number of selected component (if applicable):
livecd-tools-16.11-1.fc16.x86_64

How reproducible:
always

Steps to Reproduce:
1. sudo livecd-iso-to-pxeboot ~/iso/Fedora-17.TC3-i686-Live-Desktop.iso
2. boot it

Additional info:
Also it does not print any dots during initrd retrieval, but that's really a minor issue.
Comment 1 Kamil Páral 2012-05-09 09:43:14 EDT
I followed this guide:
https://fedorahosted.org/cobbler/wiki/HowToPxeAnyLiveCd
Comment 2 Brian Lane 2012-05-15 16:10:20 EDT
Please retry with TC5 or later. It worked for me using Fedora-17.TC5-x86_64-Live-Desktop.iso
Comment 3 Kamil Páral 2012-05-16 07:29:37 EDT
Created attachment 584934 [details]
kernel panic with F17 TC6

I have the same problem with F17 TC6.
Comment 4 Kamil Páral 2012-05-16 07:41:12 EDT
Created attachment 584940 [details]
another panic with TC6

Ok, now I know what's the reason. My colleague's laptop shows the first message, which is "initrd too large to handle, disabling initrd".

Does that mean that the particular hardware is not capable of booting it at all?
Comment 5 Brian Lane 2012-05-16 12:44:31 EDT
There is a limit to how large the initrd can be on i686. I can't tell exactly what it is from reading the kernel source.
Comment 6 Peter Jones 2012-05-16 13:48:22 EDT
Created attachment 585028 [details]
This patch makes the traceback slightly more reasonable.

This patch (against kernel) won't fix your problem, which is that you're running out of ram, but it will panic when the problem occurs instead of going on to corrupt the stack and panic then.
Comment 7 Kamil Páral 2012-05-17 06:55:38 EDT
I have correctly created and booted F17 RC1 x86_64 Live using livecd-iso-to-pxeboot. So it is really a problem only with i686 images.

Shouldn't livecd-iso-to-pxeboot print a warning if it is highly probable that the image might not boot (i686 arch)? It would be great, that would save me a lot of time. Also the guide [1], if you have write access to it, should be adjusted.

[1] https://fedorahosted.org/cobbler/wiki/HowToPxeAnyLiveCd
Comment 8 Brian Lane 2012-05-17 11:32:39 EDT
The actual limit depends on the hardware, how much ram and how things are mapped, so there is no way to set a threshold.
Comment 9 Kamil Páral 2012-05-17 16:31:15 EDT
OK. Just to add missing pieces of information, I was not able to boot i686 LiveCD over PXE even on Thinkpad T500 (Core2 Duo) with 8GB RAM.

Note You need to log in before you can comment on or make changes to this bug.