Bug 820265 - Deadlock during ldapmodify
Summary: Deadlock during ldapmodify
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: 389-ds-base
Version: 17
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rich Megginson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-05-09 13:44 UTC by Petr Viktorin
Modified: 2020-09-13 20:10 UTC (History)
4 users (show)

Fixed In Version: 389-ds-base-1.2.11.5-1.fc17
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-03-04 23:30:55 UTC
Type: Bug


Attachments (Terms of Use)
GDB session (16.94 KB, text/plain)
2012-05-09 13:44 UTC, Petr Viktorin
no flags Details
DS access log (291.71 KB, application/octet-stream)
2012-05-09 13:45 UTC, Petr Viktorin
no flags Details
DS error log (88.47 KB, application/octet-stream)
2012-05-09 13:46 UTC, Petr Viktorin
no flags Details
LDIF file (4.56 KB, application/octet-stream)
2012-05-09 13:47 UTC, Petr Viktorin
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github 389ds 389-ds-base issues 360 0 None None None 2020-09-13 20:10:20 UTC

Description Petr Viktorin 2012-05-09 13:44:43 UTC
Created attachment 583289 [details]
GDB session

Description of problem:
When installing FreeIPA, the directory server deadlocks during an ldap update.

Version-Release number of selected component (if applicable):
389-ds-base-1.2.11.1-1.fc17.x86_64

How reproducible:

Steps to Reproduce:
1. Install freeipa on F-17 and observe installation
2.
3.
  
Actual results:
Installation is stuck on "adding DNS container", with no CPU or disk activity


Expected results:
Installation succeeds in under an hour


Additional info:
The offending command issued by the IPA installer:
/usr/bin/ldapmodify -h vm-117.idm.lab.bos.redhat.com -v -f /tmp/tmpoTOfVD -x -D cn=Directory Manager -y /tmp/tmpgRB04I

Comment 1 Petr Viktorin 2012-05-09 13:45:29 UTC
Created attachment 583290 [details]
DS access log

Comment 2 Petr Viktorin 2012-05-09 13:46:08 UTC
Created attachment 583291 [details]
DS error log

Comment 3 Petr Viktorin 2012-05-09 13:47:11 UTC
Created attachment 583292 [details]
LDIF file

Comment 4 Rich Megginson 2012-05-09 14:13:04 UTC
This was fixed in 1.2.11.3 which was unfortunately revoked due to other issues that I'm currently working on.

Comment 5 Nathan Kinder 2012-05-14 20:10:23 UTC
Upstream ticket:
https://fedorahosted.org/389/ticket/360

Comment 6 Nathan Kinder 2013-03-04 23:30:55 UTC
This was fixed in 389-ds-base-1.2.11.5-1.fc17.  Closing.


Note You need to log in before you can comment on or make changes to this bug.