Bug 82029 - hpijs 1.3, deskjet 5550 w/duplexer hangs after printing last (odd) page
Summary: hpijs 1.3, deskjet 5550 w/duplexer hangs after printing last (odd) page
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: ghostscript (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-16 15:22 UTC by Jonathan Kamens
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-31 15:56:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Kamens 2003-01-16 15:22:59 UTC
I'm using CUPS, ghostscript-7.05-27, and hpis-1.3-27.  I have a Deskjet 5550
with a duplexer installed.  When I print a document with an odd number of pages
when duplexing is enabled, everything goes fine until the last page is printed,
but then the printer hangs with the page still inside it.  The green light next
to the power button is flashing.  Neither the form-feed button nor the
cancel-job button have any effect.  The only way to get the printer to spit out
the page is to hit the power button.

I suspect an hpijs bug.

Comment 1 Tim Waugh 2003-01-16 15:26:53 UTC
How are you printing?  From which application?  Also how are you enabling duplexing?

Comment 2 Jonathan Kamens 2003-01-16 15:38:35 UTC
Generating postscript from OpenOffice and printing with lpr through CUPS. 
Printing though a CUPS printer that is configured (through
redhat-config-printer) to use the hpijs-rss driver with duplexing enabled.


Comment 3 Tim Waugh 2003-01-16 15:43:16 UTC
Things to try:

a) Printing the (single-page) CUPS test page from redhat-config-printer

b) Turning off duplexing in redhat-config-printer, and telling OpenOffice to do
the duplexing (this generates PostScript that turns it on again).

Has this worked with a previous release and suddenly broken?

Comment 4 Jonathan Kamens 2003-01-16 16:40:23 UTC
Printing the test page from redhat-config-printer had the same problem.

The problem went away when I enabled duplex inside OpenOffice instead of inside
the redhat-config-printer driver configuration.

I don't know if it has worked before; I rarely use my duplexer.

Note that the version of redhat-config-printer I'm using is the one from 8.0,
not the one from Raw Hide, but I doubt this is relevant.


Comment 5 Tim Waugh 2003-01-16 16:44:30 UTC
Could you please try the rawhide version, just to be sure?

Comment 6 Jonathan Kamens 2003-01-16 16:46:48 UTC
No, unfortunately, I can't, because Raw Hide glibc is incompatible with vmware,
and redhat-config-printer is incompatible with 8.0 glibc.


Comment 7 Tim Waugh 2003-01-16 21:43:28 UTC
Reported upstream.

Comment 8 Tim Waugh 2003-03-31 15:26:04 UTC
They are unable to reproduce it.

I wonder if this still happens for you in Red Hat Linux 9.

Comment 9 Jonathan Kamens 2003-03-31 15:38:34 UTC
Yes, it still happens to me in Red Hat 9.  I also reported it upstream, and they
said they were going to use the example I gave them to reproduce it, but I
didn't hear anything more from them, so I had assumed that they hadn't gotten
around to investigating further.  See
<URL:http://sourceforge.net/forum/forum.php?thread_id=796216&forum_id=53439>.


Comment 10 Tim Waugh 2003-03-31 15:56:08 UTC
Okay.  Let's keep it tracked there.


Note You need to log in before you can comment on or make changes to this bug.