Bug 820320 - WARNING: tapset '/usr/share/systemtap/tapset/qemu-kvm.stp' has errors
WARNING: tapset '/usr/share/systemtap/tapset/qemu-kvm.stp' has errors
Status: CLOSED DUPLICATE of bug 798676
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Asias He
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-09 11:42 EDT by Eric Sandeen
Modified: 2013-10-31 20:04 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-16 01:37:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Sandeen 2012-05-09 11:42:30 EDT
When running systemtap with qemu-qvm installed, I get:

# stap -e 'probe vfs.read {exit()}'
parse error: expected literal string or number
	saw: operator '=' at /usr/share/systemtap/tapset/qemu-kvm.stp:814:8
     source:   next = $arg1;
                    ^
1 parse error.
WARNING: tapset '/usr/share/systemtap/tapset/qemu-kvm.stp' has errors, and will be skipped.


fche says:

[10:38]  <fche> next is a keyword in stap language
Comment 2 Frank Ch. Eigler 2012-05-09 11:44:00 EDT
The list of keywords to avoid is: 

probe, global, function, if, else, for, foreach, in, limit, return, delete, while, break, continue, next, string, long, try, catch
Comment 3 juzhang 2012-05-10 04:56:48 EDT
Hi,Eric

Please use the qemu-kvm>=qemu-kvm-0.12.1.2-2.287.el6 and have a try,thanks
FYI
Bug 798676 - do not use next as a variable name in qemu-kvm systemtap tapset(verified)
Comment 5 RHEL Product and Program Management 2012-07-10 04:51:43 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 6 RHEL Product and Program Management 2012-07-10 22:07:23 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 7 Ronen Hod 2012-07-16 01:37:33 EDT

*** This bug has been marked as a duplicate of bug 798676 ***

Note You need to log in before you can comment on or make changes to this bug.