Bug 820328 - RHEL7 ppc changes boot order
RHEL7 ppc changes boot order
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: lab controller (Show other bugs)
0.9
Unspecified Unspecified
unspecified Severity unspecified (vote)
: 0.9.0
: ---
Assigned To: Bill Peck
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-09 12:15 EDT by Bill Peck
Modified: 2012-06-26 02:41 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 824801 (view as bug list)
Environment:
Last Closed: 2012-06-26 02:41:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Peck 2012-05-09 12:15:53 EDT
Description of problem:

RHEL7 ppc install changes boot order so that subsequent installs will fail because it won't boot from the network anymore.

Version-Release number of selected component (if applicable):
0.8.2

How reproducible:
Everytime you install RHEL7 on ppc
Comment 1 andrew 2012-05-09 12:23:02 EDT
Current work around is in the Job XML to add the following
<ks_append>
<![CDATA[

%pre --interpreter /bin/bash
#!/bin/bash
nvram --print-config=boot-device > /mnt/sysimage/root/boot-device.bak
%end
           
%post --interpreter /bin/bash
#!/bin/bash
if [ -e /root/boot-device.bak ]; then
nvsetenv boot-device "$(cat /root/boot-device.bak)"
logger "Read boot-device.bak from /root"
else
logger "Error: /root/boot-device.bak does not exist!"
%end  
    										]]>	</ks_append>

This will capture the boot device order and then re-set the boot order to what was captured.
Comment 2 Bill Peck 2012-05-11 14:56:53 EDT
pushed to gerrit for review

http://gerrit.beaker-project.org/#/c/1059/1
Comment 5 Dan Callaghan 2012-06-26 02:41:28 EDT
Beaker 0.9.0 has been released.

Note You need to log in before you can comment on or make changes to this bug.