Bug 820331 - Vim syntax file for sshdconfig is missing newer keyword entries
Summary: Vim syntax file for sshdconfig is missing newer keyword entries
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vim
Version: 6.2
Hardware: All
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Karsten Hopp
QA Contact: Filip Holec
URL:
Whiteboard:
Depends On:
Blocks: 947784 1159824 1404257
TreeView+ depends on / blocked
 
Reported: 2012-05-09 16:19 UTC by Kwan Lowe
Modified: 2016-12-13 13:36 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1404257 (view as bug list)
Environment:
Last Closed: 2015-07-22 06:27:23 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1310 normal SHIPPED_LIVE vim bug fix and enhancement update 2015-07-20 17:53:38 UTC

Description Kwan Lowe 2012-05-09 16:19:20 UTC
Description of problem:
The vim syntax file does not contain the most recent SSHD configuration keywords, including:

AllowAgentForwarding 
AuthorizedKeysCommand 
AuthorizedKeysCommandRunAs 
ChrootDirectory 
GSSAPIKeyExchange 
GSSAPIStrictAcceptorCheck 
KerberosUseKuserok 
MaxSessions 


Version-Release number of selected component (if applicable):
vim-common-7.2.411-1.6.el6.i686


How reproducible:

Edit the /etc/ssh/sshd_config file. Keywords such as PermitTunnel should be highlighted but are not.

Steps to Reproduce:
1. Edit sshd_config
2.
3.
  
Actual results:
PermitTunnel, and other keywords, are not highlighted.

Expected results:
Keywords should be highlighted.

Additional info:

Comment 2 RHEL Product and Program Management 2012-09-07 05:34:06 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.

Comment 6 Karsten Hopp 2015-03-31 14:02:46 UTC
Syntax file updated

Comment 10 errata-xmlrpc 2015-07-22 06:27:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1310.html


Note You need to log in before you can comment on or make changes to this bug.