Bug 82037 - vim rpm klobbers the setup file
Summary: vim rpm klobbers the setup file
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: vim (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 82044 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-16 17:49 UTC by David McKellar
Modified: 2007-04-18 16:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-10 12:57:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David McKellar 2003-01-16 17:49:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.2)
Gecko/20021120 Netscape/7.01

Description of problem:
The rpm for VIM always overwrites /usr/share/vim/vim61/macros/vimrc.
Not very polite - it should rename it to vimrc.rpmsave at the very least.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Make a custom change to /usr/share/vim/vim61/macros/vimrc
2. Install the vim rpm
3. Look in /usr/share/vim/vim61/macros/vimrc - your custom change will be gone
forever
    

Additional info:

Comment 1 Karsten Hopp 2003-01-16 18:46:15 UTC
*** Bug 82044 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.